Bug 704069 - [or_IN] Invalid date format error in subscription manager gui
[or_IN] Invalid date format error in subscription manager gui
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.1
i386 Linux
high Severity high
: rc
: ---
Assigned To: Bryan Kearney
John Sefler
: i18n, Translation
Depends On:
Blocks: rhsm-rhel62 818461
  Show dependency treegraph
 
Reported: 2011-05-11 23:32 EDT by Kenichi Takemura
Modified: 2014-08-04 18:03 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
No description necessary
Story Points: ---
Clone Of:
: 818461 (view as bug list)
Environment:
Last Closed: 2011-12-06 12:14:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Invalid date format error (346.15 KB, image/png)
2011-05-11 23:33 EDT, Kenichi Takemura
no flags Details

  None (edit)
Description Kenichi Takemura 2011-05-11 23:32:29 EDT
Description of problem:

When running subscription manager gui in or_IN locale, the gui detects 'Invalid date format' error after having subscribed to a contract.

I am not familiar with or_IN language but it appears all numeric characters are in local languages not Arabic numbers which may cause this error.

This error message shows up often and make some parts of the tool useless.

Version-Release number of selected component (if applicable):
subscription-manager-firstboot-0.95.11-1.el6.i686
subscription-manager-debuginfo-0.95.8-1.el6.i686
subscription-manager-gnome-0.95.11-1.el6.i686
subscription-manager-0.95.11-1.el6.i686

How reproducible:
100%

Steps to Reproduce:
1. LANG=or_IN.utf8 subscription-manager-gui
2. Register system
3. Subscribe to a contract
4. Click My subscription tab
  
Actual results:
Invalid date format error

Expected results:
I expect date are present in Arabic Number

Additional info:
Comment 1 Kenichi Takemura 2011-05-11 23:33:23 EDT
Created attachment 498429 [details]
Invalid date format error
Comment 3 RHEL Product and Program Management 2011-05-12 02:00:10 EDT
Since RHEL 6.1 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.
Comment 4 A S Alam 2011-05-12 02:54:21 EDT
with date button, when click on next icon, no calendar opened and error shown
----
(subscription-manager-gui:3309): libglade-WARNING **: unknown property `orientation' for class `GtkVBox'
Traceback (most recent call last):
  File "/usr/share/rhsm/subscription_manager/gui/widgets.py", line 425, in _button_clicked
    self._calendar_window.set_transient_for(
AttributeError: 'DatePicker' object has no attribute 'get_window'
---
as trackback.

it appears in all languages, including English. So, it seems Application error.
Comment 6 John Sefler 2011-05-12 13:59:56 EDT
Version:
[root@jsefler-onprem-6workstation ~]# rpm -qa | grep subscription-manager
subscription-manager-firstboot-0.95.11-1.el6.x86_64
subscription-manager-gnome-0.95.11-1.el6.x86_64
subscription-manager-0.95.11-1.el6.x86_64
subscription-manager-debuginfo-0.95.11-1.el6.x86_64

Based on comment #4, I wonder if "it appears in all languages, including English" on i686 machines only?  Need to investigate.  I was only able to reproduce this bug on my x86_64 client ONLY with LANG=or_IN.utf8.  No other languages were a problem.
Comment 7 A S Alam 2011-05-12 23:42:02 EDT
(In reply to comment #4)
> with date button, when click on next icon, no calendar opened and error shown
> ----
> (subscription-manager-gui:3309): libglade-WARNING **: unknown property
> `orientation' for class `GtkVBox'
> Traceback (most recent call last):
>   File "/usr/share/rhsm/subscription_manager/gui/widgets.py", line 425, in
> _button_clicked
>     self._calendar_window.set_transient_for(
> AttributeError: 'DatePicker' object has no attribute 'get_window'
> ---
> as trackback.
> 
> it appears in all languages, including English. So, it seems Application error.

this was different issue, already reported by Ken for RHEL6, clone for RHEL5.7 (bug #704408)
Comment 8 Chris Duryee 2011-08-08 12:34:34 EDT
This was fixed in master during the 5.7 work, 0.96.5+ (680bb38148b5068281e2a1582d255d53e43d0711 or higher) should have the fix
Comment 12 Shwetha Kallesh 2011-08-26 04:32:59 EDT
There is no Invalid date format error now,but the numbers are not in Oriya yet..
Comment 15 Shwetha Kallesh 2011-08-29 03:54:47 EDT
Moving the bug to verified
Comment 16 Bryan Kearney 2011-11-14 12:40:32 EST
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No description necessary
Comment 17 errata-xmlrpc 2011-12-06 12:14:10 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1695.html

Note You need to log in before you can comment on or make changes to this bug.