This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 704090 - Your system may be seriously compromised! /usr/sbin/NetworkManager tried to load a kernel module.
Your system may be seriously compromised! /usr/sbin/NetworkManager tried to l...
Status: CLOSED DUPLICATE of bug 704431
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: selinux-policy (Show other bugs)
6.0
i586 Linux
high Severity high
: rc
: ---
Assigned To: Daniel Walsh
BaseOS QE Security Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-12 02:55 EDT by Alexander Todorov
Modified: 2011-05-13 08:55 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-13 08:55:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Todorov 2011-05-12 02:55:25 EDT
Description of problem:
This morning after turning on my laptop I got a SELinux denial. 

Your system may be seriously compromised! /usr/sbin/NetworkManager tried to load
a kernel module.


node=(removed) type=AVC msg=audit(1305182229.634:19): avc:  denied  { sys_module } for  pid=1644 comm="NetworkManager" capability=16  scontext=system_u:system_r:NetworkManager_t:s0 tcontext=system_u:system_r:NetworkManager_t:s0 tclass=capability

node=(removed) type=SYSCALL msg=audit(1305182229.634:19): arch=40000003 syscall=54 success=no exit=-19 a0=d a1=8915 a2=bfea853c a3=bfea853c items=0 ppid=1 pid=1644 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="NetworkManager" exe="/usr/sbin/NetworkManager" subj=system_u:system_r:NetworkManager_t:s0 key=(null)



Version-Release number of selected component (if applicable):
NetworkManager-0.8.1-5.el6_0.1.i686
selinux-policy-3.7.19-54.el6_0.5.noarch
kernel-2.6.32-71.29.1.el6.i686


How reproducible:


Steps to Reproduce:
1. Boot the system and log in into GNOME
2. I have a mobile 3G connection configured in NM. It is configured to connect automatically
3.
  
Actual results:
NM connected to the mobile network but I got this SELinux error.

Expected results:
No errors

Additional info:
I haven't seen this before and indeed when booting with kernel-2.6.32-71.24.1 there's no error. I remember updating the kernel package yesterday so it might be it.
Comment 3 Miroslav Grepl 2011-05-13 08:55:53 EDT

*** This bug has been marked as a duplicate of bug 704431 ***

Note You need to log in before you can comment on or make changes to this bug.