Bug 70417 - Cirrus driver fails with "Cannot read V_BIOS"
Cirrus driver fails with "Cannot read V_BIOS"
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2002-08-01 05:02 EDT by Tethys
Modified: 2007-04-18 12:45 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-08-08 07:42:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Output of lspci -v (3.56 KB, text/plain)
2002-08-08 07:41 EDT, Tethys
no flags Details
XFree86 config file (4.53 KB, text/plain)
2002-08-08 07:41 EDT, Tethys
no flags Details
XFree86 log file (41.92 KB, text/plain)
2002-08-08 07:42 EDT, Tethys
no flags Details

  None (edit)
Description Tethys 2002-08-01 05:02:59 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020529

Description of problem:
When trying to use a Cirrus Logic GD5430 card with XFree86, it
fails with the error "Cannot read V_BIOS". I get the same error
whether X is configured with "XFree86 -configure", or with
Xconfigurator. I'm using this as a second head. The primary
head is a Matrox G450 (FYI, I'm not running the second head
off the G450 because I don't have enough RAM on the card to
support DRI if I do that).

The card is listed as being supported at

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Configure X server (with either X -configure or Xconfigurator)
2. Run startx

Actual Results:  Only primary head is active. Second head recevies no signal,
and turns itself off due to power saving.

Expected Results:  Both heads should be active.

Additional info:

The surrounding context in the XFree86 log file is:

(II) Loading sub module "vgahw"
(II) LoadModule: "vgahw"
(II) Reloading /usr/X11R6/lib/modules/libvgahw.a
(II) CIRRUS(1): vgaHWGetIOBase: hwp->IOBase is 0x03b0, hwp->PIOOffset is 0x0000
(II) Loading sub module "int10"
(II) LoadModule: "int10"
(II) Loading /usr/X11R6/lib/modules/linux/libint10.a
(II) Module int10: vendor="The XFree86 Project"
        compiled for 4.2.0, module version = 1.0.0
        ABI class: XFree86 Video Driver, version 0.5
(II) CIRRUS(1): initializing int10
Requesting insufficient memory window!: start: 0xfdd00000 end: 0xfdffffff size
Requesting insufficient memory window!: start: 0xfdd00000 end: 0xfdffffff size
Requesting insufficient memory window!: start: 0xfdd00000 end: 0xfdffffff size
(EE) CIRRUS(1): Cannot read V_BIOS
(**) CIRRUS(1): Depth 8, (--) framebuffer bpp 8
(==) CIRRUS(1): Default visual is PseudoColor
(II) UnloadModule: "cirrus"
(II) UnloadModule: "int10"
(II) Unloading /usr/X11R6/lib/modules/linux/libint10.a
(II) UnloadModule: "vgahw"
(II) UnloadModule: "cirrus_alpine"
Comment 1 Mike A. Harris 2002-08-04 13:55:16 EDT
Attach your X config and full X server log using the link below.
Comment 2 Tethys 2002-08-08 07:41:10 EDT
Created attachment 69505 [details]
Output of lspci -v
Comment 3 Tethys 2002-08-08 07:41:53 EDT
Created attachment 69506 [details]
XFree86 config file
Comment 4 Tethys 2002-08-08 07:42:22 EDT
Created attachment 69507 [details]
XFree86 log file
Comment 5 Mike A. Harris 2002-11-24 05:01:34 EST
This isn't really a supported configuration, nor one that would be easy
to set up and even try to reproduce.  Try removing all cards, and configuring
each standalone, and resolving whatever problems come up, save your config,
then swap cards and do the same.  Then try both simultaneously while
using the special data from each.

Also look for an option in your CMOS to initialize non-primary vga devices
Comment 6 Tethys 2002-11-25 04:25:48 EST
Each card works perfectly when used standalone. It's only when used
together that they fail. Just curious, though. What about this makes
it an "unsupported configuration"? I'm afraid it just has the air of
wanting to clean up the bug database, rather than actually trying to
resolve the problems contained therein...
Comment 7 Mike A. Harris 2002-11-25 07:48:35 EST
What makes it an "officially" unsupported configuration, is that not all
hardware is capable of working in multihead configurations, and separately
from that, not all hardware that _is_ capable of doing so is supported
by XFree86 to do so.  In addition to that, it requires some help from the
computer's BIOS, and many many systems do NOT properly initialize more
than one video card if present.  XFree86 has some code which attempts
to softboot the cards BIOS in this case, but it can not always work.

Since this is a very complex thing in general to resolve, and is often
not possible to resolve, or requires physical direct access to the given
machine - it is not officially supported.

Also, mixing DRI on one head and not on another head is also not supported.
And to clarify that, I mean not supported by DRI and XFree86, and so not
supported by Red Hat either.

Aside from all of that, I would have continued to try and help you
troubleshoot the problem _anyway_.  However, you treat me like I'm
trying to blow you off, so I'm not sure I will bother now.

Basically, you're trying to do something which in theory looks like it
would be nice to do, but in practice is much more complicated than that,
and very difficult if not impossible to fix.  Not sure what you expect.

XFree86 does not support everything under the sun.  Sorry.
Comment 8 Tethys 2002-11-25 08:27:36 EST
Huh? But I currently *do* mix DRI on my primary head, and non-DRI on
the other head (this is with both heads powered by the G450). The reason
for trying a second card is to get DRI working at full resolution on my
main screen. Currently, I have to restart X at a lower resolution every
time I want to play UT or Q3A.

Are they any two card multihead setups that *are* officially supported?

As for how I treat you, trust me, I intended no offence, and I'm sorry if
I caused any. I've worked in a support dept before, and I know how thankless
it can be at times. But perhaps a few words about *why* it was unsupported
would have been a good idea, rather than just 3 months of silence followed
by "closed wontfix -- unsupported" would have made it seem less suspicious...
Comment 9 Mike A. Harris 2002-11-25 09:35:53 EST
>Are they any two card multihead setups that *are* officially supported?

They're not supported in the sense that we will go to the ends of the earth
if you have a bug to report, no.  If multihead works, great.  If it does
not work, then if it is easily possible for me to configure a system locally
and reproduce the problem here where I have physical access, then it might
be possible to reproduce and possibly determine the problem.

However, considering how many people set up such a setup, it is a VERY low
priority, and might not get any attention ever.  Multihead setups with
different hardware can behave very differently from motherboard to
motherboard, and in order to reproduce such a problem a user may be having
might require having that users own computer on my desk, which is generally
impossible.  And even if it were possible, it is of very low priority.

So, in general, if multihead works, great.  If it does not, then it is up
to the user to troubleshoot why, and _prove_ it is a bug, and not just
some hardware screwup local to their system.  Nobody can fix this type
of thing without having hardware to duplicate it, which is nigh impossible
in dualhead setups as you need to have all of the exact hardware, including
the motherboard, and perhaps other stuff.

I do have a Matrox G450.  I do not have a Cirrus Logic 5465, although I
do have specifications for it.

If you want best chances of dualhead working, then I suggest using the
dualheadedness of the G450 itself.

Please note that what you are trying to do, is not a run of the mill setup.
It is quite a customized special purpose setup.  Your best bet, if you
really want to get this to work (if it is possible), is to contact
the XFree86 mailing list:  xpert@xfree86.org

Hope this helps.

Note You need to log in before you can comment on or make changes to this bug.