This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 704185 - Add version info to the status API call
Add version info to the status API call
Status: CLOSED WORKSFORME
Product: Candlepin
Classification: Community
Component: candlepin (Show other bugs)
0.5
Unspecified Solaris
unspecified Severity unspecified
: ---
: ---
Assigned To: Bryan Kearney
John Sefler
:
Depends On:
Blocks: rhsm-rhel62
  Show dependency treegraph
 
Reported: 2011-05-12 07:33 EDT by Lukas Zapletal
Modified: 2015-05-14 11:23 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-07 09:55:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Lukas Zapletal 2011-05-12 07:33:56 EDT
Hello,

we would like to know the version number of Candlepin server, because we often run into issues when using incompatible API.

Is there any way to get the version number from the API call? If not the status call would be nice place to add it.

Thanks
Comment 1 Justin Sherrill 2011-06-07 09:55:12 EDT
Candlepin has a version already. http://localhost:8443/candlepin/status

$ curl -k https://localhost:8443/candlepin/status
{"version":"0.4.1","result":true,"release":"1%{?dist}"}

On an rpm install it gets filled out with the right release, when
running from git it shows the above.

Closing!

Note You need to log in before you can comment on or make changes to this bug.