Bug 704191 - secadm_r doesn't have write permission to selinux_config_t
Summary: secadm_r doesn't have write permission to selinux_config_t
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: selinux-policy   
(Show other bugs)
Version: 6.1
Hardware: All
OS: Linux
urgent
medium
Target Milestone: rc
: ---
Assignee: Miroslav Grepl
QA Contact: Milos Malik
URL:
Whiteboard:
Keywords: ZStream
: 704189 (view as bug list)
Depends On:
Blocks: RHEL62CCC 712194 846801 846802
TreeView+ depends on / blocked
 
Reported: 2011-05-12 11:55 UTC by Ramon de Carvalho Valle
Modified: 2012-10-16 12:27 UTC (History)
7 users (show)

Fixed In Version: selinux-policy-3.7.19-95.el6
Doc Type: Bug Fix
Doc Text:
Previously, a secadm SELinux user was not allowed to modify SELinux configuration files. With this update, the relevant SELinux policy has been fixed and the secadm SELinux user can now modify these configuration files.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-06 10:07:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1511 normal SHIPPED_LIVE selinux-policy bug fix and enhancement update 2011-12-06 00:39:17 UTC

Description Ramon de Carvalho Valle 2011-05-12 11:55:36 UTC
Description of problem:
It seems that secadm_r doesn't have write permission to both default_context_t and selinux_config_t. I expected it would have write permission at least to selinux_config_t.

[root/secadm_r/SystemLow@ntc242 ~]# sesearch --role_source secadm_r -s secadm_t -t selinux_config_t --allow
Found 11 semantic av rules:
   allow secadm_usertype selinux_config_t : file { ioctl read getattr lock open } ;
   allow secadm_usertype selinux_config_t : dir { ioctl read getattr lock search open } ;
   allow secadm_usertype selinux_config_t : lnk_file { read getattr } ;
   allow secadm_t selinux_config_t : file { getattr relabelfrom relabelto } ;
   allow secadm_t selinux_config_t : dir { ioctl read getattr lock relabelfrom relabelto search open } ;
   allow secadm_t selinux_config_t : lnk_file { getattr relabelfrom relabelto } ;
   allow secadm_t selinux_config_t : chr_file { getattr relabelfrom relabelto } ;
   allow secadm_t selinux_config_t : blk_file { getattr relabelfrom relabelto } ;
   allow secadm_t selinux_config_t : sock_file { getattr relabelfrom relabelto } ;
   allow secadm_t selinux_config_t : fifo_file { getattr relabelfrom relabelto } ;
   allow secadm_usertype file_type : filesystem getattr ;

[root/secadm_r/SystemLow@ntc242 ~]#

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 2 Miroslav Grepl 2011-05-16 14:19:57 UTC
I will fix this one.

Comment 3 Ramon de Carvalho Valle 2011-05-16 14:31:17 UTC
Thank you very much Miroslav.

Comment 4 Miroslav Grepl 2011-05-24 14:06:35 UTC
*** Bug 704189 has been marked as a duplicate of this bug. ***

Comment 5 Miroslav Grepl 2011-05-24 14:27:48 UTC
Fixed in selinux-policy-3.7.19-95.el6

Comment 13 Tomas Capek 2011-06-20 13:59:50 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Previously, a secadm SELinux user was not allowed to modify SELinux configuration files. With this update, the relevant SELinux policy has been fixed and the secadm SELinux user can now modify these configuration files.

Comment 16 errata-xmlrpc 2011-12-06 10:07:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1511.html


Note You need to log in before you can comment on or make changes to this bug.