Bug 704198 - s390x: systemd should open /dev/console on terminal
s390x: systemd should open /dev/console on terminal
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
15
s390x Linux
high Severity high
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks: ZedoraTracker
  Show dependency treegraph
 
Reported: 2011-05-12 08:16 EDT by Jan Stodola
Modified: 2011-05-12 10:02 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-12 10:02:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Stodola 2011-05-12 08:16:50 EDT
Description of problem:
After installation of Fedora 15 for s390x and rebooting into installed system, root is not able to login via x3270 terminal emulator:

...
Fedora release 15 (Lovelock)  
Kernel 2.6.38.3-18.fc15.s390x on an s390x (ttyS0)
  
rtt7.xxx login: root
root 
Password: xxx
 
Login incorrect 


This is caused by starting "ttyS0" on terminal instead of "console". With RHEL6 or Fedora 14, "console" is opened on terminal:


Fedora release 14 (Laughlin)  
Kernel 2.6.35.6-45.fc14.s390x on an s390x (console)  
  
rtt6 login: root
root  
Password: xxx
  
Last login: Thu May 12 07:37:29 from vpn1-xxx
Ýroot@rtt6 ~¨# tty
tty  
/dev/console  


To be consistent with previous releases, systemd should open /dev/console on terminal, since "console" is allowed in /etc/securetty, "ttyS0" is not allowed:

[root@rtt7 ~]# grep ttyS0 /etc/securetty 
[root@rtt7 ~]# grep console /etc/securetty 
console


Version-Release number of selected component (if applicable):
systemd-24-1.fc15.s390x

How reproducible:
always

Steps to Reproduce:
1. install F15 for s390x
2. reboot
3. try to login as root via terminal
  
Actual results:
Login fails

Expected results:
root can login via terminal
Comment 2 Dan Horák 2011-05-12 10:02:56 EDT
After a discussion with Lennart it is an issue in pam_securetty where it must check also for devices from /sys/class/tty/console/active in addition to the console= kernel parameter. New bug will be filed.

Note You need to log in before you can comment on or make changes to this bug.