Bug 70437 - Installation from ISO images on hard disk fails
Installation from ISO images on hard disk fails
Status: CLOSED NOTABUG
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda (Show other bugs)
limbo
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-01 07:51 EDT by Need Real Name
Modified: 2007-04-18 12:45 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-02 07:42:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-08-01 07:51:32 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1b) Gecko/20020722

Description of problem:
Installation from ISO images downloaded to a FAT32 partition on the
target hard disk failed.

How reproducible:
Always

Steps to Reproduce:
1.Download the "limbo" ISO images to a logical FAT32 partition
2.Boot from a "boot.img" floppy
3.Push Enter in response to the first screen.
4.Select language and keyboard (en, se-latin1)
5.Select media mode (Hard drive)
6.Select the partition (hda6) and path (/)

	

Actual Results (console messages):
Running Anaconda...
Probing for video card: RIVA TNT2
Probing for monitor type: Unable to probe
Probing for mouse type: Generic 3-button PS/2
Graphical installation not available for hd installs. Starting text mode.
Traceback (most recent calls last):
/usr/bin/anaconda  line 603  in ?
  rootPath)
/usr/src/build/129715-i386/install/usr/lib/anaconda/harddrive.py line  235 in
__init__
/usr/src/build/129715-i386/install/usr/lib/anaconda/image.py line 288 in
findIsoImages
/usr/src/build/129715-i386/install/usr/lib/anaconda/text.py line 276 in
messageWindow
/usr/src/build/129715-i386/install/usr/lib/anaconda/text.py line 116 in __init__
/usr/lib/python2.2/site-packages/snack.py line 547 in ButtonChoiceWindow
AttributeError: 'NoneType' object has no attribute 'height'
install exited abnormally
sending termination signals
(more messages, finally "you may safely reboot your system")

Expected Results:  Continued installer dialogue.

Additional info:

Workaround: Use some other installation method (I went for
FTP).
Comment 1 Jeremy Katz 2002-08-02 01:42:28 EDT
Did you allow the installer to media check your ISOs, and did it succeed?
Comment 2 Need Real Name 2002-08-02 06:54:25 EDT
I have now tried to start the installation with "linux mediacheck". When 
I reach the screen where I specify the ISO images location, I tried specifying 
a non-existent directory on the correct partition. So far so good, the 
installer said "Failed to read directory ... No such file or directory". 
 
Next I tried to specify the wrong partition and an existing directory. 
This produced the message "Device /dev/hda2 does not appear to contain 
Red Hat CDROM images". Also reasonable. 
 
Finally I specified the right partition and the right directory. I then 
got the same crash as before. 
 
For comparison I tried "linux mediacheck" on a Red Hat 7.3 box where I 
still have the ISO images lying around. The installer complained "Failed 
to read directory /mnt/source" but apart from that things went well. 
 
I also tried to create the structure /mnt/source on /dev/hda6 and move 
the ISO images there, but that did not help. The complaint "Failed to 
read directory /mnt/source" is still issued, and after that there is the 
check (well ... there is no report of success though), and then the 
screen "Welcome to Red Hat Linux". After that a normal installation 
dialogue sequence follows.
Comment 3 Need Real Name 2002-08-02 07:42:51 EDT
I have now checked the MD5 sums of the five ISO images; it turned out 
that no 4 is broken! It is less than 500 MB in size so there is no chance 
that it could be correct.
Comment 4 Need Real Name 2002-08-02 09:52:36 EDT
I have now downloaded the 4th ISO image and checked that its MD5
is correct.

And, good news, install from hard drive now works.

So, it was all a mistake on my part.

The "linux mediacheck" install option is a bit disappointing in that
it does not have a sanity check that catched my problem. Here is an
idea; since the boot.img installer is specific to one particular Red
Hat release, why not let it know about the exact sizes of the
corresponding ISO images? It could then easily detect and diagnose
this kind of condition.

A still more ambitious check could be done if the boot.img code
knows the expected MD5 sums. However, it takes a while to compute
the MD5s, so an impatient user might not want to have it (though it
could be part of the "linux mediacheck" option perhaps?).

Note You need to log in before you can comment on or make changes to this bug.