Bug 704372 - tolua++ segmentation fault while building Clanlib06
Summary: tolua++ segmentation fault while building Clanlib06
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: lua   
(Show other bugs)
Version: 15
Hardware: powerpc Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tim Niemueller
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-05-12 22:41 UTC by Karsten Hopp
Modified: 2011-10-11 22:15 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-11 22:15:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Karsten Hopp 2011-05-12 22:41:17 UTC
Description of problem:
the Clanlib06 spec file uses tolua++ to prepare some sources. tolua++ aborts with a segmentation fault, although it looks like it happens in liblua:

Core was generated by `tolua++ -o Sources/Lua/clanbindings.cpp Sources/Lua/clanbindings.pkg'.
Program terminated with signal 11, Segmentation fault.
#0  0x0ff88150 in luaV_execute (L=0x107c0008, nexeccalls=5) at lvm.c:389
389         const Instruction i = *pc++;
Missing separate debuginfos, use: debuginfo-install glibc-2.13.90-9.ppc
(gdb) bt
#0  0x0ff88150 in luaV_execute (L=0x107c0008, nexeccalls=5) at lvm.c:389
#1  0x0ff7c59c in luaD_call (L=0x107c0008, func=0x107c0290, nResults=<optimized out>) at ldo.c:377
#2  0x0ff7b5a4 in luaD_rawrunprotected (L=0x107c0008, f=0xff754e4 <f_call>, ud=0xff97a4b8) at ldo.c:116
#3  0x0ff7c7c0 in luaD_pcall (L=0x107c0008, func=<optimized out>, u=<optimized out>, old_top=64, ef=<optimized out>) at ldo.c:463
#4  0x0ff771c4 in lua_pcall (L=0x107c0008, nargs=<optimized out>, nresults=-1, errfunc=<optimized out>) at lapi.c:821
#5  0x0ff8b754 in luaB_pcall (L=0x107c0008) at lbaselib.c:377
#6  0x0ff7c0fc in luaD_precall (L=0x107c0008, func=<optimized out>, nresults=2) at ldo.c:319
#7  0x0ff88c74 in luaV_execute (L=0x107c0008, nexeccalls=1) at lvm.c:590
#8  0x0ff7c59c in luaD_call (L=0x107c0008, func=0x107c0270, nResults=<optimized out>) at ldo.c:377
#9  0x0ff7b5a4 in luaD_rawrunprotected (L=0x107c0008, f=0xff754e4 <f_call>, ud=0xff97a8d8) at ldo.c:116
#10 0x0ff7c7c0 in luaD_pcall (L=0x107c0008, func=<optimized out>, u=<optimized out>, old_top=32, ef=<optimized out>) at ldo.c:463
#11 0x0ff771c4 in lua_pcall (L=0x107c0008, nargs=<optimized out>, nresults=0, errfunc=<optimized out>) at lapi.c:821
#12 0x0ffd5f64 in tolua_dobuffer (L=0x107c0008, B=<optimized out>, size=<optimized out>, name=<optimized out>) at src/lib/tolua_map.c:699
#13 0x10001234 in tolua_tolua_open (tolua_S=0x107c0008) at src/bin/toluabind.c:8058
#14 0x10000a00 in main (argc=4, argv=0xff97abf4) at src/bin/tolua.c:152


Version-Release number of selected component (if applicable):
lua-5.1.4-8.fc15

Steps to Reproduce:
1. try to build ClanLib06 (on ppc, if that matters)
2.
3.
  

Additional info:
> rpm -q tolua++
tolua++-1.0.93-2.fc15

Comment 1 Karsten Hopp 2011-05-12 22:42:44 UTC
(gdb) p *L
$1 = {next = 0x1087a4f0, tt = 8 '\b', marked = 98 'b', status = 0 '\000', top = 0x107fba78, base = 0x107fb928, l_G = 0x107c0080, ci = 0x107eaa20, 
  savedpc = 0x11, stack_last = 0x107fc4a8, stack = 0x107fb788, end_ci = 0x107eac60, base_ci = 0x107ea978, stacksize = 216, size_ci = 32, nCcalls = 2, 
  baseCcalls = 0, hookmask = 0 '\000', allowhook = 1 '\001', basehookcount = 0, hookcount = 0, hook = 0, l_gt = {value = {gc = 0x107c0528, p = 0x107c0528, 
      n = 2.8877104096134679e-229, b = 276563240}, tt = 5}, env = {value = {gc = 0x107c2da0, p = 0x107c2da0, n = 2.90400198706782e-229, b = 276573600}, 
    tt = 5}, openupval = 0x0, gclist = 0x0, errorJmp = 0xff97a1e0, errfunc = 0}

Comment 2 Tim Niemueller 2011-05-13 20:58:11 UTC
Does the problem happen only on ppc or also on other architectures? I have no ppc machine and no intention to fix this bug if it is ppc specific. If it's broken only there I'll exclude the arch from building.

Maybe there is a PPC SIG which can help to debug and fix it? Otherwise you should try to report the problem to upstream and get it fixed there.

Comment 3 Karsten Hopp 2011-05-17 12:51:01 UTC
As this is package with seems to be used only for some games, an excludearch would probably be ok, even if I'd prefer a fix ;-)
Please make sure to follow the excludearch guidelines from 
http://fedoraproject.org/wiki/PackagingGuidelines#Architecture_Build_Failures so that we're able to lookup the reason for this change later on.

Comment 4 Tim Niemueller 2011-10-11 22:15:20 UTC
Added ExcludeArch in master branch. Not issuing an update just for this, but next clone and build should fail "properly".


Note You need to log in before you can comment on or make changes to this bug.