Bug 704403 - lxsession does not start openbox-lxde
lxsession does not start openbox-lxde
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: lxsession (Show other bugs)
14
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Christoph Wickert
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-12 23:01 EDT by Richard Shaw
Modified: 2011-05-16 13:12 EDT (History)
1 user (show)

See Also:
Fixed In Version: 0.3.0-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-16 13:12:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Shaw 2011-05-12 23:01:41 EDT
Description of problem:
At some point lxsession stopped starting openbox-lxde which caused windows to loose their decorators.

Version-Release number of selected component (if applicable):
lxsession-0.4.4-1.fc14

How reproducible:
Every time I login

Steps to Reproduce:
1. Login from GDM
2.
3.
  
Actual results:
openbox-lxde is not started

Expected results:
openbox-lxde started

Additional info:
A bit of googling let me to the directory:
~/.config/lxsession/LXDE
which contained two files: "config" and "desktop.conf"

The contents of "config" was an exact match (diff) to:
/etc/xdg/lxsession/LXDE/desktop.conf

so as the existing desktop.conf was not empty I added the contents of config to desktop.conf and once again openbox-lxde was started on login.

Is there a problem with the program or script that creates the per user desktop.conf that copies from /etc to config instead of desktop.conf?
Comment 1 Christoph Wickert 2011-05-16 13:12:41 EDT
The program that changes desktop.conf is either lxappearance (for the [GTK] section) or lxinput (for [Mouse] and [Keyboard]. The problem you are seeing was probably caused by lxinput-0.1.1-3.fc14. I had to add a patch until the issues were solved properly in 0.3.0 by upstream.

LXDE lacks a proper release management: Dependent updates are not made at the same time and some components are not released but only updated in GIT. Things like your problem are the consequence.

Meanwhile the issue is fixed. If you still experience it with a new user account or after deleting ~/.config/lxsession/LXDE, please reopen this bug and tell me when versions of lxappearance, lxinput, lxde-common and pcmanfm you have installed.

Note You need to log in before you can comment on or make changes to this bug.