This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 704409 - guest's snapshot got kernel panic after dd a big file then shutdown
guest's snapshot got kernel panic after dd a big file then shutdown
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.7
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Kevin Wolf
Virtualization Bugs
:
Depends On:
Blocks: Rhel5KvmTier3
  Show dependency treegraph
 
Reported: 2011-05-12 23:43 EDT by Golita Yue
Modified: 2011-08-01 12:26 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-01 12:26:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
guest-kernel-panic-serial.log (19.63 KB, application/octet-stream)
2011-05-12 23:43 EDT, Golita Yue
no flags Details

  None (edit)
Description Golita Yue 2011-05-12 23:43:11 EDT
Created attachment 498679 [details]
guest-kernel-panic-serial.log

Description of problem:
Guest(rhel4.9-64) kernel panic during shutdown.

Version-Release number of selected component (if applicable):
kvm-83-232.el5
kernel 2.6.18-259.el5

How reproducible:
only once

Steps to Reproduce:
1. create a snapshot 
#qemu-img create -b RHEL-4.9-64.raw -f qcow2 sn1.qcow2

2. boot up new created sn1.qcow2 with cmd
******** cmd line ********
#/usr/libexec/qemu-kvm -drive file='sn1.qcow2',index=0,if=ide,media=disk,cache=none,format=qcow2 -net nic,vlan=0,model=e1000,macaddr='9a:ee:93:df:01:06' -net tap,vlan=0,ifname='t0-091953-J5dh',script='qemu-ifup-switch',downscript='no' -m 32768 -smp 8,cores=1,threads=1,sockets=8 -cpu qemu64,+sse2 -soundhw ac97 -spice port=8000,disable-ticketing -qxl 1 -rtc-td-hack -M rhel5.6.0 -boot c  -usbdevice tablet -no-kvm-pit-reinjection
**************************

3. create big file in guest
#dd if=/dev/zero of=/tmp/file_sn1 bs=1M count=1000

4. shutdown guest
#shutdown -h now
  
Actual results:
guest kernel panic

Expected results:
guest shutdown normally

Additional info:
Tested 20 times, hit this bug only once.
Comment 3 Kevin Wolf 2011-07-29 03:51:14 EDT
Doesn't look related to the snapshot at all. I suspect this was only a coincidence.

Golita, did you experience the problem again since then?
Comment 4 Kevin Wolf 2011-08-01 12:26:19 EDT
No response, so I'm assuming that it really happened only once and is most likely unrelated to qemu. Closing.

Note You need to log in before you can comment on or make changes to this bug.