Bug 70445 - Corrupt cd-rom data transfers
Summary: Corrupt cd-rom data transfers
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 7.3
Hardware: athlon
OS: Linux
medium
high
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-08-01 14:27 UTC by Vaclav "sHINOBI" Misek
Modified: 2007-04-18 16:45 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-02 09:26:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Vaclav "sHINOBI" Misek 2002-08-01 14:27:38 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98; T312461)

Description of problem:
I have corrupted data transfers from my cd-rom/cdrw

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1.Copy any larger file from cdrom/cdrw drive
2.Unpack or check MD5-sum
3.
	

Actual Results:  The file is copied without any error messages, but during 
unpacking or installing there are errors (rpm checksum etc.). I found, that 
after enabling DMA for cdrom, this problem disappears. This bug appeared with 
version 7.3.

Additional info:

1. Comp Athlon 1800+, 256 MB DDR RAM, ABIT KR7, Cyberhome DVD drive
2. Comp Athlon 1700+, 256 MB DDR RAM, Soltek SL-75DRV4, NEC CDRW

Comment 1 Arjan van de Ven 2002-08-01 14:30:31 UTC
do you know if dma is enabled for the cdrom drive?

Comment 2 Vaclav "sHINOBI" Misek 2002-08-02 09:26:44 UTC
In default it is disabled from 7.3 and in /etc/proc/ide/hdc/settings is 0 in 
DMA collumn. After enabling DMA the transfers are without corruptions 
(through /etc/sysconfig/harddiskhdc). As I wrote the same think happened with 
different board and drive. I had already problems with verifying Redhat install 
CD`s. The checksum was sometimes OK, but sometimes not. With DMA enabled, 
checksums were OK everytime.

Comment 3 Vaclav "sHINOBI" Misek 2002-08-26 11:27:54 UTC
Seems to be fixed in latest kernels 2.4.18-5 and 2.4.18-10. Thanks.


Note You need to log in before you can comment on or make changes to this bug.