Bug 704519 - denemo fails to build with guile-2.0.1
Summary: denemo fails to build with guile-2.0.1
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: denemo
Version: 19
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Roy Rankin
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 678238
TreeView+ depends on / blocked
 
Reported: 2011-05-13 14:11 UTC by Miroslav Lichvar
Modified: 2013-04-20 19:24 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-04-20 19:24:21 UTC
Type: ---


Attachments (Terms of Use)
Try to search for guile-2.0 before guile-1.8 (866 bytes, patch)
2011-11-03 19:59 UTC, Joonas Sarajärvi
no flags Details | Diff

Description Miroslav Lichvar 2011-05-13 14:11:25 UTC
The guile package in rawhide is planned for update to a new major release.
In a test rebuild of all packages depending on guile, denemo has failed to build.

Rebuild results:
http://mlichvar.fedorapeople.org/tmp/guile/rebuild/

New guile packages:
http://mlichvar.fedorapeople.org/tmp/guile/

Please close this bug if a new upstream version of denemo which works
with the new guile is available or if you think the current version can be
easily fixed. It doesn't have to be commited in fedora git, we are just trying
to find out if we need to delay the guile update (or make a guile-compat
package).

Comment 1 Joonas Sarajärvi 2011-11-03 19:59:04 UTC
Created attachment 531651 [details]
Try to search for guile-2.0 before guile-1.8

I am not very familiar with autoconf files, but I think this makes the configure stage first try for guile-2.0 and fall back to guile-1.8 if 2.0 is not available.

Comment 2 Fedora Update System 2013-04-03 11:54:39 UTC
denemo-1.0.0-0.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/denemo-1.0.0-0.fc19

Comment 3 Fedora Update System 2013-04-03 16:13:35 UTC
Package denemo-1.0.0-0.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing denemo-1.0.0-0.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-4775/denemo-1.0.0-0.fc19
then log in and leave karma (feedback).

Comment 4 Fedora End Of Life 2013-04-03 18:21:45 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 19 development cycle.
Changing version to '19'.

(As we did not run this process for some time, it could affect also pre-Fedora 19 development
cycle bugs. We are very sorry. It will help us with cleanup during Fedora 19 End Of Life. Thank you.)

More information and reason for this action is here:
https://fedoraproject.org/wiki/BugZappers/HouseKeeping/Fedora19

Comment 5 Fedora Update System 2013-04-20 19:24:24 UTC
denemo-1.0.0-0.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.