Bug 704636 - ipheth module in kernel is not latest version after update
ipheth module in kernel is not latest version after update
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
15
i686 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-13 15:52 EDT by Jon Stoski
Modified: 2011-06-07 00:35 EDT (History)
5 users (show)

See Also:
Fixed In Version: kernel-2.6.38.7-30.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-07 00:35:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jon Stoski 2011-05-13 15:52:24 EDT
Description of problem:
ipheth module which is integrated into kernel has an update in source.

It allows tethering the iphone as a network device.  How long before this change is reflected in the kernel update packages?  Sorry if this is not the place to ask but I have searched for a place to ask this question and haven't been able to find anywhere suitable.

Version-Release number of selected component (if applicable):
Fedora 15

How reproducible:
every time

Steps to Reproduce:
1.Fedora 15 fresh install, or updated beta
2.plug in iphone
3.Network manager times out trying to use phone as network device.
  
Actual results:
This is fixable by compiling the newest source from the git repo.

Expected results:
changes integrated into kernel.

Additional info:
Comment 1 Chuck Ebbert 2011-05-16 19:59:55 EDT
It looks like the fix for that bug is queued for 2.6.38.7:

From 9c412942a0bb19ba18f7bd939d42eff1e132a901 Mon Sep 17 00:00:00 2001
From: Ben Hutchings <bhutchings@solarflare.com>
Date: Tue, 3 May 2011 07:49:25 +0000
Subject: ipheth: Properly distinguish length and alignment in URBs and skb
Comment 2 Fedora Update System 2011-06-02 10:48:41 EDT
kernel-2.6.38.7-30.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/kernel-2.6.38.7-30.fc15
Comment 3 Fedora Update System 2011-06-03 01:32:18 EDT
Package kernel-2.6.38.7-30.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-2.6.38.7-30.fc15'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/kernel-2.6.38.7-30.fc15
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2011-06-07 00:35:15 EDT
kernel-2.6.38.7-30.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.