Bug 704703 - Error processing jpg files, 'module' object has no attribute 'Image' in phatch
Summary: Error processing jpg files, 'module' object has no attribute 'Image' in phatch
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: phatch
Version: rawhide
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Narasimhan
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-05-14 07:56 UTC by Narasimhan
Modified: 2011-07-04 18:51 UTC (History)
3 users (show)

Fixed In Version: phatch-0.2.7-7.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-07-04 18:50:48 UTC
Type: ---


Attachments (Terms of Use)
comparison of Phatch data on left and original on right (201.10 KB, image/png)
2011-06-25 21:22 UTC, Jeff Guerdat
no flags Details
original image (3.89 MB, image/jpeg)
2011-06-26 12:23 UTC, Jeff Guerdat
no flags Details
image after resized by Phatch (89.40 KB, image/jpeg)
2011-06-26 12:24 UTC, Jeff Guerdat
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 646035 None None None Never

Internal Links: 646035

Description Narasimhan 2011-05-14 07:56:02 UTC
Description of problem:
1) While processing jpg files, phatch throws an error
'module' object has no attribute 'Image'. This occurs  consistently.

Version-Release number of selected component (if applicable):
phatch-0.2.7

Steps to Reproduce:
1. Create some actions in phatch
2. Run the actions on some jpg files

  
Actual results:
Processing of files throws an error. Phatch allows the user to either abort or continue processing the files.

Expected results:
Processing completes.

Additional info:
This error occurs due to api incompatibility with the new version of pyexiv2

https://bugs.launchpad.net/phatch/+bug/585169

Comment 1 Narasimhan 2011-06-24 17:40:03 UTC
Ok. I have a fix for the issue. I will submit an update.

Comment 2 Fedora Update System 2011-06-24 18:45:22 UTC
phatch-0.2.7-6.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/phatch-0.2.7-6.fc15

Comment 3 Fedora Update System 2011-06-24 18:45:29 UTC
phatch-0.2.7-5.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/phatch-0.2.7-5.fc14

Comment 4 Jeff Guerdat 2011-06-24 20:16:22 UTC
phatch-0.2.7-6.fc15 works fine for my limited test.  Yay!

Comment 5 Narasimhan 2011-06-25 06:55:45 UTC
Hi Jeff,
Thanks for testing. If possible, could you test with a image which has some exif tags and see whether the resultant image has the same set of exif tags? I am seeing that some exif tags are not present after phatch processes it. I am still investigating this issue. If I am not able to find a solution or reason for this, I will probably pull out the update.

Comment 6 Narasimhan 2011-06-25 07:30:49 UTC
Another update. The exif tag issue is solved. There are two other issues with api compatibility , one related to saving comments and another related to thumbnail data. I am working on those issues now.

Comment 7 Narasimhan 2011-06-25 09:53:48 UTC
Issues reported in comment 6 are fixed. Will submit a new update. I have bumped the the evr to 0.2.7-7 just to avoid any problems with the update.

Comment 8 Fedora Update System 2011-06-25 10:17:51 UTC
phatch-0.2.7-7.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/phatch-0.2.7-7.fc15

Comment 9 Fedora Update System 2011-06-25 10:18:00 UTC
phatch-0.2.7-6.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/phatch-0.2.7-6.fc14

Comment 10 Jeff Guerdat 2011-06-25 12:58:31 UTC
I'm not up on EXIF info but the latest update certainly looks better than the previous in this regard.  The one thing I note is that the "Maker Note" section (don't know if that's how it's actually identified or if that's what EOG viewer calls it) is noticeably different, with many items removed and others with invalid data.  I personally don't care but I won't speak for others.

Comment 11 Narasimhan 2011-06-25 13:08:03 UTC
Hi Jeff,
Do you see missing information or invalid data with this new update or was it with the previous one? Please confirm.

Comment 12 Jeff Guerdat 2011-06-25 13:33:42 UTC
0.2.7.6-f15 definitely had missing data relative to both the original images as well as 0.2.7.7-f15.  0.2.7.7-f15 is the one that I noticed the invalid data in - I never got that far in 0.2.7.6-f15 what with the additional missing data.

Comment 13 Narasimhan 2011-06-25 14:06:48 UTC
Thanks for testing,

Do you mean that the new picture and the original have same values for all the exif tags (including invalid data in both cases) for 0.2.7.7-f15 . I tested with a picture locally. All fields in the original and new one are same. The Maker note field has increased in size but eog shows invalid data in both cases.

Comment 14 Fedora Update System 2011-06-25 19:57:12 UTC
Package phatch-0.2.7-7.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing phatch-0.2.7-7.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/phatch-0.2.7-7.fc15
then log in and leave karma (feedback).

Comment 15 Jeff Guerdat 2011-06-25 21:21:04 UTC
Actually, the Phatch'ed image has a smaller Maker Notes section compared to the original and has fields that the original doesn't.  The original has no invalid data.  I'm attaching a snapshot with the Phatch image properties on the left and the original on the right.  It's not complete but gives you the idea.  I can upload both images for your own comparison if you like.

Comment 16 Jeff Guerdat 2011-06-25 21:22:06 UTC
Created attachment 509928 [details]
comparison of Phatch data on left and original on right

Comment 17 Narasimhan 2011-06-26 06:56:29 UTC
Hi Jeff,

I checked the attachment. Looks like those tags with invalid data are not valid exif at all but need to confirm why they are showing up in the first place. If you could share the images, that will be helpful.

Thanks,

Comment 18 Jeff Guerdat 2011-06-26 12:23:14 UTC
Created attachment 509959 [details]
original image

Comment 19 Jeff Guerdat 2011-06-26 12:24:28 UTC
Created attachment 509960 [details]
image after resized by Phatch

for comparison with original EXIF data

Comment 20 Jeff Guerdat 2011-06-26 12:25:12 UTC
Original and modified images uploaded for EXIF comparison.

Comment 21 Narasimhan 2011-06-26 12:47:35 UTC
Thanks  Jeff. Marker Note seems to be a proprietary part of the metadata. I will see whether the existing data can in some way be just retained. I will also check how phatch works with previous version of pyexiv2 to see how this marker note is handled.

Comment 22 Fedora Update System 2011-07-04 18:50:43 UTC
phatch-0.2.7-6.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 23 Fedora Update System 2011-07-04 18:51:19 UTC
phatch-0.2.7-7.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.