Bug 704795 - Gnome 3 drops to fallback on radeon driver
Gnome 3 drops to fallback on radeon driver
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
rawhide
Unspecified Linux
unspecified Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-14 21:23 EDT by jimmyb
Modified: 2011-06-21 14:19 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-16 16:22:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Xorg.0.log (63.27 KB, text/plain)
2011-06-06 09:17 EDT, Manuel Morales
no flags Details

  None (edit)
Description jimmyb 2011-05-14 21:23:15 EDT
Description of problem:

I have what I believe is a graphics card that should support the Standard experience of Gnome 3, but I am placed into Fallback mode upon logging in. 

Version-Release number of selected component (if applicable):

gnome-shell-3.0.1-4.fc15.x86_64

Actual results:

Placed into Fallback experience


Expected results:

Placed into Standard experience

Additional info:

    01:00.0 VGA compatible controller: ATI Technologies Inc RV380 [Radeon X600 (PCIE)] (prog-if 00 [VGA controller])
    Subsystem: ATI Technologies Inc Device 0602
    Flags: bus master, fast devsel, latency 0, IRQ 45
    Memory at f0000000 (64-bit, prefetchable) [size=128M]
    Memory at fe9e0000 (64-bit, non-prefetchable) [size=64K]
    I/O ports at dc00 [size=256]
    Expansion ROM at fea00000 [disabled] [size=128K]
    Capabilities: [50] Power Management version 2
    Capabilities: [58] Express Endpoint, MSI 00
    Capabilities: [80] MSI: Enable+ Count=1/1 Maskable- 64bit+
    Capabilities: [100] Advanced Error Reporting
    Kernel driver in use: radeon
    Kernel modules: radeon, radeonfb
Comment 1 Owen Taylor 2011-05-26 13:22:51 EDT
- What is the total resolution of all monitors you have attached?
- What is the output of 'glxinfo | grep renderer'
- Can you attach the output of dmesg and /var/log/Xorg.0.log' as attachments?
Comment 2 Manuel Morales 2011-05-26 15:25:52 EDT
I have the identical problem. Disconnecting one of my two monitors fixes the problem, although I'd like to use both. Should I also include the info requested above?
Comment 3 Manuel Morales 2011-06-06 09:17:34 EDT
Created attachment 503219 [details]
Xorg.0.log
Comment 4 Manuel Morales 2011-06-06 09:20:17 EDT
Total resolution = 1024x768 and 1280x1024
glxinfo | grep renderer = OpenGL renderer string: Gallium 0.4 on ATI RV370
Comment 5 advasile 2011-06-07 09:57:24 EDT
Same problem here, with a couple of Dell 19" screens. Total desktop size is (2x1600)x1200. 

Running on an up-to-date F15 with Radeon X600 graphics.
Comment 6 Manuel Morales 2011-06-14 08:55:52 EDT
Should version be updated to 15? Or should a new bug be filed?
Comment 7 Manuel Morales 2011-06-14 08:59:37 EDT
What other info is needed to move this bug along?
Comment 8 Jerome Glisse 2011-06-16 16:22:41 EDT
Total resolution is too big, your gpu can't do 3d above 2560x2560
Comment 9 Jerome Glisse 2011-06-16 16:23:07 EDT
*** Bug 707410 has been marked as a duplicate of this bug. ***
Comment 10 Manuel Morales 2011-06-17 14:15:34 EDT
Could we reopen this?

(1280*1024+1024*768) < 2560*2560

This gpu *should* be able to handle this resolution ...
Comment 11 Manuel Morales 2011-06-17 14:23:31 EDT
Also, with respect to Comment 5, is the limit based on total number of pixels or the maximum resolution in either dimension?
Comment 12 Jerome Glisse 2011-06-17 17:51:25 EDT
Maximum resolution in either dimension

(1280*1024+1024*768) might fails because Xserver stills try to allocate its screen buffer using the native edid resolution supplied by your monitor. Try Virtual "2304 1024" in your xorg.conf
Comment 13 Jerome Glisse 2011-06-17 17:53:13 EDT
Ok i misread the bug this is why we want 1 person -> 1 bug for gpu

It should work with 1280*1024+1024*768
Comment 14 Manuel Morales 2011-06-21 11:30:10 EDT
Adding Virtual "2304 1024" fixes this but I still think this should be re-opened as a bug. In my view, Xserver should allocate its screen buffer based on the user-specified resolution - not the maximum possible by the monitor.
Comment 15 Jerome Glisse 2011-06-21 14:19:35 EDT
There is no good answer to that kind of configuration. Anytime we change something we make a bunch of user unhappy while making other happy.

Note You need to log in before you can comment on or make changes to this bug.