Bug 70483 - 8-bit depth cause fonts to become "transparent"
8-bit depth cause fonts to become "transparent"
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: XFree86 (Show other bugs)
limbo
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks: 67218
  Show dependency treegraph
 
Reported: 2002-08-01 13:57 EDT by Kris Urquhart
Modified: 2007-04-18 12:45 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-30 20:37:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
X log (26.53 KB, text/plain)
2002-08-02 15:02 EDT, Kris Urquhart
no flags Details
16-bit config file (3.21 KB, text/plain)
2002-08-02 15:03 EDT, Kris Urquhart
no flags Details
8-bit config file (3.24 KB, text/plain)
2002-08-02 15:07 EDT, Kris Urquhart
no flags Details
8-bit log file (25.17 KB, text/plain)
2002-08-06 09:20 EDT, Kris Urquhart
no flags Details

  None (edit)
Description Kris Urquhart 2002-08-01 13:57:52 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows 98; Win 9x 4.90)

Description of problem:
The default install of limbo came up with 1024x768, 16 bit depth, and all is 
well.

I ran redhat-config-xfree86 to increase the resolution to 1600x1200, which 
required a drop to 8-bit depth since I have only 2M of video ram.  After 
restarting X, the fonts were the same color as the background in both gnome-
terminal and xterm.  Changing the text color only affected the cursor.

Reducing the resolution to 1024x768 did not fix the problem.  Increasing the 
depth to 16 bit did restore the font colors.


Version-Release number of selected component (if applicable):
XFree86-4.2.0-56

How reproducible:
Always

Steps to Reproduce:
1. change display depth to 8 bits
2. restart x
3. watch fonts disappear
	

Actual Results:  Fonts became "transparent"

Expected Results:  Normal font display

Additional info:

ATI Mach64 3D Rage IIC (2M video ram)
ViewSonic P220f 21" display
Comment 1 Mike A. Harris 2002-08-02 10:20:34 EDT
What about lower resolutions at 8 bit depth?

Attach your X server config file and log to the report please.
Comment 2 Kris Urquhart 2002-08-02 14:59:29 EDT
The problem is with 8-bit depth, any resolution (I even tried 640x480).  I also
tried 15-bit depth, which worked fine at several resolutions.
Comment 3 Kris Urquhart 2002-08-02 15:02:15 EDT
Created attachment 68544 [details]
X log
Comment 4 Kris Urquhart 2002-08-02 15:03:39 EDT
Created attachment 68545 [details]
16-bit config file
Comment 5 Kris Urquhart 2002-08-02 15:07:12 EDT
Created attachment 68546 [details]
8-bit config file
Comment 6 Mike A. Harris 2002-08-06 03:43:24 EDT
The log file is from the "working" 16 bit run.  I can't debug 8 bit
problems with a 16 bit logfile.  Please attach buggy logfile.
Comment 7 Kris Urquhart 2002-08-06 09:20:17 EDT
Created attachment 69084 [details]
8-bit log file
Comment 8 Kris Urquhart 2002-08-06 09:21:00 EDT
Sorry, I forgot that the X log files rotates.
Comment 9 Kris Urquhart 2002-08-22 01:58:42 EDT
Well, I installed null and tried to reproduce this bug.  Gnome-terminal now
crashes with a SIGSEGV.  Since my monitor was not autoprobed properly (bug
72228), I am not sure what is cause and what is effect at this point.  Any hints
on how to further debug would be appreciated.
Comment 10 Owen Taylor 2002-08-22 10:25:16 EDT
Does gnome-terminal crash just in 8-bit or always? What about
other gnome apps? Can you get a backtrace of gnome-terminal?
[run it as:

 (gdb) gnome-terminal

 from within an xterm, and when it crashes do (gdb) bt
]
Comment 11 Kris Urquhart 2002-08-22 11:05:29 EDT
This gnome-terminal crash only happens in 8-bit mode.  I tried a few other gnome
apps (-calculator, -dictionary, and -text-editor) and they work fine.  Here is
the gnome-terminal backtrace:

[kurquhart@oscar kurquhart]$ gdb gnome-terminal
GNU gdb Red Hat Linux (5.2.1-2)
Copyright 2002 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-redhat-linux"...(no debugging symbols found)...
(gdb) r
Starting program: /usr/bin/gnome-terminal 
[New Thread 1024 (LWP 11267)]

** (gnome-terminal:11267): CRITICAL **: file pango-context.c: line 310
(pango_context_get_language): as
sertion `context != NULL' failed

** (gnome-terminal:11267): CRITICAL **: file pango-context.c: line 310
(pango_context_get_language): as
sertion `context != NULL' failed

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 1024 (LWP 11267)]
0x408d19b9 in XftDrawCharSpec () from /usr/lib/libXft.so.2
(gdb) bt
#0  0x408d19b9 in XftDrawCharSpec () from /usr/lib/libXft.so.2
#1  0x4004474d in vte_terminal_draw_cells () from /usr/lib/libvte.so.2
#2  0x40044c47 in vte_terminal_draw_row () from /usr/lib/libvte.so.2
#3  0x400450f5 in vte_terminal_paint () from /usr/lib/libvte.so.2
#4  0x40045b6f in vte_terminal_expose () from /usr/lib/libvte.so.2
#5  0x4039a0e4 in _gtk_marshal_BOOLEAN__BOXED () from /usr/lib/libgtk-x11-2.0.so.0
#6  0x4080d467 in g_type_class_meta_marshal () from /usr/lib/libgobject-2.0.so.0
#7  0x4080d0c0 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#8  0x40821369 in signal_emit_unlocked_R () from /usr/lib/libgobject-2.0.so.0
#9  0x40820689 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#10 0x403dcfcf in gtk_signal_emit () from /usr/lib/libgtk-x11-2.0.so.0
#11 0x40480353 in gtk_widget_event_internal () from /usr/lib/libgtk-x11-2.0.so.0
#12 0x40398b1c in gtk_main_do_event () from /usr/lib/libgtk-x11-2.0.so.0
#13 0x4053c66f in gdk_window_process_updates_internal () from
/usr/lib/libgdk-x11-2.0.so.0
#14 0x4053c70a in gdk_window_process_all_updates () from
/usr/lib/libgdk-x11-2.0.so.0
#15 0x4033c8ea in gtk_container_idle_sizer () from /usr/lib/libgtk-x11-2.0.so.0
#16 0x4087cc83 in g_idle_dispatch () from /usr/lib/libglib-2.0.so.0
#17 0x40879f65 in g_main_dispatch () from /usr/lib/libglib-2.0.so.0
#18 0x4087af98 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#19 0x4087b2ad in g_main_context_iterate () from /usr/lib/libglib-2.0.so.0
#20 0x4087ba1f in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#21 0x4039839f in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#22 0x080581a6 in main ()
#23 0x420155c4 in __libc_start_main () from /lib/i686/libc.so.6
(gdb) Quit
(gdb)
Comment 12 Kris Urquhart 2002-08-22 11:08:15 EDT
Another note: when I first filed this bug under limbo, both gnome-terminal and
xterm exhibited the 8-bit invisible font problem, but xterm fonts are fine in
8-bit mode under null.
Comment 13 Kris Urquhart 2002-08-30 20:37:28 EDT
Good news: this works in XFree86-4.2.0-67.6, thanks!
Comment 14 Mike A. Harris 2002-09-01 03:37:53 EDT
Nothing has changed in XFree86 WRT this bug, so it must have been
a gnome-terminal bug or somesuch.  If it recurs, please reopen
this bug against the component which is failing.

Thanks.

Note You need to log in before you can comment on or make changes to this bug.