Bug 704882 - Button "2" is not working in kcalc in german locale
Button "2" is not working in kcalc in german locale
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kdeutils (Show other bugs)
15
i686 Linux
unspecified Severity low
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-15 13:47 EDT by Marc Muehlfeld
Modified: 2011-12-03 21:40 EST (History)
7 users (show)

See Also:
Fixed In Version: qt-4.7.4-7.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-26 18:00:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 256591 None None None Never

  None (edit)
Description Marc Muehlfeld 2011-05-15 13:47:28 EDT
Description of problem:
I can press any number on my keyboard. All I can use for input - except "2". 


Version-Release number of selected component (if applicable):
kcalc 2.8 of KDE 4.6.2


How reproducible:
Press "2" on your keyboard. The program doesn't reccocnize any input.


Steps to Reproduce:
1. Open kcalc
2. Press "2". Nothing happens.

  
Actual results:
None.


Expected results:
"2" should appear.


Additional info:
I use german language here. If I switch kcalc to english (help / switch language application), the bug is gone.

I also found a bug at kde.org:
https://bugs.kde.org/show_bug.cgi?id=256591


The problem already was already existing in F14 and is still in F15.
Comment 1 Rex Dieter 2011-05-15 17:47:59 EDT
Let's continue to track this one upstream, thanks for the confirmation.
Comment 2 Rex Dieter 2011-11-16 10:09:41 EST
Re-opened, upstream determined cause to be a faulty patch included qt.  Will fix here, downstream.
Comment 3 Marc Muehlfeld 2011-11-16 14:32:22 EST
Just for information: In F16, it's working.
Comment 4 Kevin Kofler 2011-11-16 14:41:02 EST
That's because we stopped forward-porting the discontinued kde-qt patches when we moved to Qt 4.8.
Comment 5 Fedora Update System 2011-11-16 16:37:48 EST
qt-4.7.4-7.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/qt-4.7.4-7.fc15
Comment 6 Fedora Update System 2011-11-16 16:38:21 EST
qt-4.7.4-7.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/qt-4.7.4-7.fc14
Comment 7 Fedora Update System 2011-11-17 18:26:28 EST
Package qt-4.7.4-7.fc14:
* should fix your issue,
* was pushed to the Fedora 14 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing qt-4.7.4-7.fc14'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-15998/qt-4.7.4-7.fc14
then log in and leave karma (feedback).
Comment 8 Marc Muehlfeld 2011-11-18 02:39:32 EST
Sorry. I can't test this any more. I don't have F14 or F15 running any more. I'm meanwhile having F16 on my computer, where it works.
Comment 9 Fedora Update System 2011-11-26 18:00:01 EST
qt-4.7.4-7.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2011-12-03 21:40:38 EST
qt-4.7.4-7.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.