Bug 704927 - autofs should support paged results from ldap server
Summary: autofs should support paged results from ldap server
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: autofs
Version: 6.1
Hardware: All
OS: Linux
urgent
medium
Target Milestone: rc
: ---
Assignee: Ian Kent
QA Contact: yanfu,wang
URL:
Whiteboard:
Depends On: 563956
Blocks: 691311
TreeView+ depends on / blocked
 
Reported: 2011-05-16 03:10 UTC by Ian Kent
Modified: 2014-02-21 07:30 UTC (History)
13 users (show)

Fixed In Version: autofs-5.0.5-32
Doc Type: Bug Fix
Doc Text:
Clone Of: 563956
Environment:
Last Closed: 2011-12-06 17:58:46 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1723 normal SHIPPED_LIVE autofs bug fix and enhancement update 2011-12-06 01:02:10 UTC

Comment 1 Ian Kent 2011-05-16 03:14:09 UTC
A couple of problems with the paged LDAP query implementation
were identified and fixed during QA of RHEL-5.7 and now need
to be fixed in RHEL-6.

Comment 3 yanfu,wang 2011-05-16 04:50:48 UTC
hi Ian,
Could you illustrate the detailed problem and if QE still use bz563956 to do verification?

Comment 4 Ian Kent 2011-05-16 08:59:49 UTC
(In reply to comment #3)
> hi Ian,
> Could you illustrate the detailed problem and if QE still use bz563956 to do
> verification?

Sorry, I've removed the RHTSDone entry for now.
Once I work out what is going wrong and fix it I'll need to
write a specific test that checks function on the two archs
concerned.

Comment 5 Ian Kent 2011-07-26 09:01:43 UTC
(In reply to comment #4)
> (In reply to comment #3)
> > hi Ian,
> > Could you illustrate the detailed problem and if QE still use bz563956 to do
> > verification?
> 
> Sorry, I've removed the RHTSDone entry for now.
> Once I work out what is going wrong and fix it I'll need to
> write a specific test that checks function on the two archs
> concerned.

This last comment is incorrect.
We have another bug to cover the case I was referring to above.

The bugzillas test bz563956 has been updated to check autofs
function with LDAP configurations that caused a problem during
RHEL-5 development, the reason for raising this bug.

The problem was related to limits set on the LDAP server and the
interaction between soft and hard limit settings and the need for
autofs to adjust the number of results requested to suite these
settings. You can see these setting being set in test bz563956 to
check that autofs functions with them.

So, the autofs bugzillas test bz563956 can be used to verify this
bug.

Ian

Comment 7 yanfu,wang 2011-08-25 06:00:37 UTC
bz563956 passed when run autofs regression testing, job links pls refer to
below:
i386: https://beaker.engineering.redhat.com/jobs/123937
x86_64: https://beaker.engineering.redhat.com/jobs/123442
s390x: https://beaker.engineering.redhat.com/jobs/123318
ppc64: https://beaker.engineering.redhat.com/jobs/123317

Comment 8 errata-xmlrpc 2011-12-06 17:58:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1723.html


Note You need to log in before you can comment on or make changes to this bug.