Bug 704937 - Segmentation fault when looking up '*.'
Summary: Segmentation fault when looking up '*.'
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: autofs
Version: 6.1
Hardware: x86_64
OS: Linux
low
high
Target Milestone: rc
: ---
Assignee: Ian Kent
QA Contact: yanfu,wang
URL:
Whiteboard:
Depends On: 570783
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-05-16 04:03 UTC by Ian Kent
Modified: 2011-12-06 17:59 UTC (History)
8 users (show)

Fixed In Version: autofs-5.0.5-32
Doc Type: Bug Fix
Doc Text:
Clone Of: 570783
Environment:
Last Closed: 2011-12-06 17:59:08 UTC
Target Upstream Version:


Attachments (Terms of Use)
Patch - fix wildcard map entry match (1.01 KB, patch)
2011-06-21 13:20 UTC, Ian Kent
no flags Details | Diff
autofs test packages (2.76 MB, application/x-bzip)
2011-06-21 20:37 UTC, Dave Wysochanski
no flags Details
autofs test packages, v2 (2.76 MB, application/x-compressed-tar)
2011-07-01 17:06 UTC, Dave Wysochanski
no flags Details
Updated patch from bz570783 (1.40 KB, patch)
2011-07-01 17:09 UTC, Dave Wysochanski
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1723 normal SHIPPED_LIVE autofs bug fix and enhancement update 2011-12-06 01:02:10 UTC

Comment 1 Ian Kent 2011-06-21 13:20:43 UTC
Created attachment 505827 [details]
Patch - fix wildcard map entry match

This patch should fix the problem reported here.

Note that it is missing a hunk (from the upstream patch)
because that hunk has already been applied in a patch already
present in the package.

Comment 3 Dave Wysochanski 2011-06-21 20:11:04 UTC
Test packages (x86_64 and i386) now available at:
http://download.devel.redhat.com/brewroot/scratch/dwysocha/task_3416779/

Comment 4 Dave Wysochanski 2011-06-21 20:37:25 UTC
Created attachment 505889 [details]
autofs test packages

Contains:
autofs-5.0.5-31.el6.sf00483021.TEST.i686.rpm
autofs-5.0.5-31.el6.sf00483021.TEST.src.rpm
autofs-5.0.5-31.el6.sf00483021.TEST.x86_64.rpm
autofs-debuginfo-5.0.5-31.el6.sf00483021.TEST.i686.rpm
autofs-debuginfo-5.0.5-31.el6.sf00483021.TEST.x86_64.rpm

Comment 9 Dave Wysochanski 2011-07-01 17:06:33 UTC
Created attachment 510899 [details]
autofs test packages, v2

These test packages include the updated patch from https://bugzilla.redhat.com/show_bug.cgi?id=570783, which is here:
https://bugzilla.redhat.com/attachment.cgi?id=414713

Comment 10 Dave Wysochanski 2011-07-01 17:09:46 UTC
Created attachment 510900 [details]
Updated patch from bz570783

Comment 13 yanfu,wang 2011-10-13 02:04:47 UTC
reproduced on RHEL6.1:
[root@dell-pec6145-01 ~]# rpm -qa|grep autofs
autofs-5.0.5-31.el6.x86_64
[root@dell-pec6145-01 ~]# uname -a
Linux dell-pec6145-01.lab.bos.redhat.com 2.6.32-131.0.15.el6.x86_64 #1 SMP Tue May 10 15:42:40 EDT 2011 x86_64 x86_64 x86_64 GNU/Linux

[root@dell-pec6145-01 ~]# cat /etc/auto.master 
/test	auto.test
[root@dell-pec6145-01 ~]# cat /etc/auto.test 
* -rw,intr,hard rhel6-nfs:/export/&

[root@dell-pec6145-01 ~]# /etc/init.d/autofs start

[root@dell-pec6145-01 ~]# ls -l /test/*.
ls hung and automount gone:
[root@dell-pec6145-01 ~]# ps -ef|grep automount
root      6737  6700  0 00:53 ttyS1    00:00:00 grep automount\

Finial, interrupt the ls command and return with "^Cls: cannot access /test/*.: No such file or directory"

snippet of /var/log/messages:
Oct 12 00:47:45 dell-pec6145-01 kernel: automount[6487]: segfault at 98 ip 000077
f853c945410 sp 00007f85362af930 error 6 in lookup_file.so[7f853c93e000+1b000]
Oct 12 00:47:45 dell-pec6145-01 abrt[6494]: saved core dump of pid 6171 (/usr/sbb
in/automount) to /var/spool/abrt/ccpp-1318394865-6171.new/coredump (36933632 bytt
es)
Oct 12 00:47:45 dell-pec6145-01 abrtd: Directory 'ccpp-1318394865-6171' creationn
 detected
Oct 12 00:47:45 dell-pec6145-01 abrtd: Registered Database plugin 'SQLite3'
Oct 12 00:47:46 dell-pec6145-01 abrtd: New crash /var/spool/abrt/ccpp-13183948655
-6171, processing

verified on autofs-5.0.5-39.el6:
[root@intel-s3e37-01 ~]# ls -l /test/*.
ls: cannot access /test/*.: No such file or directory
[root@intel-s3e37-01 ~]# ps -ef|grep automount
root     45934     1  0 00:57 ?        00:00:00 automount --pid-file /var/run/autofs.pid
root     45981  9949  0 01:00 pts/0    00:00:00 grep automount
[root@intel-s3e37-01 ~]# /etc/init.d/autofs status
automount (pid  45934) is running...

and automation jobs passed on all arches also:
i386: https://beaker.engineering.redhat.com/jobs/142158
x86_64: https://beaker.engineering.redhat.com/jobs/142109
s390x: https://beaker.engineering.redhat.com/jobs/142108
ppc64: https://beaker.engineering.redhat.com/jobs/142302

Comment 14 errata-xmlrpc 2011-12-06 17:59:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1723.html


Note You need to log in before you can comment on or make changes to this bug.