Bug 705068 - product-id plugin displays "duration"
product-id plugin displays "duration"
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.2
Unspecified Unspecified
low Severity low
: rc
: ---
Assigned To: Bryan Kearney
John Sefler
:
: 705062 (view as bug list)
Depends On: 705062
Blocks: rhsm-rhel62
  Show dependency treegraph
 
Reported: 2011-05-16 10:49 EDT by Chris Duryee
Modified: 2011-12-06 12:14 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 705062
Environment:
Last Closed: 2011-12-06 12:14:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Duryee 2011-05-16 10:49:26 EDT
+++ This bug was initially created as a clone of Bug #705062 +++

Description of problem:

The product-id yum plugin displays the duration of the cert check for every plugin run. For example:

----------
  Installing     : zsh-4.3.10-5.fc14.x86_64                                                                                                               1/1 
duration: 1779(ms)
Installed products updated.
--------
There is no reason to display the duration, this is only useful to developers.


Version-Release number of selected component (if applicable): 0.95.5.15
Comment 1 Chris Duryee 2011-05-17 11:20:24 EDT
Fixed on master branch in 2fd2004c04ea993867c90d062520b8315a1d982e, version 0.96.2
Comment 3 Chris Duryee 2011-05-18 14:07:43 EDT
*** Bug 705062 has been marked as a duplicate of this bug. ***
Comment 6 John Sefler 2011-09-08 10:50:56 EDT
Verifying Version...
[root@jsefler-stage-6server ~]# rpm -q subscription-manager
subscription-manager-0.96.7-1.el6.x86_64
[root@jsefler-stage-6server ~]# rpm -q python-rhsm
python-rhsm-0.96.10-1.el6.noarch


After registering and subscribing using stage test environment....

[root@jsefler-stage-6server ~]# yum install zsh
Loaded plugins: product-id, refresh-packagekit, subscription-manager
Updating certificate-based repositories.
rhel-6-server-rpms                                                                                                      | 2.4 kB     00:00     
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package zsh.x86_64 0:4.3.10-4.1.el6 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

===============================================================================================================================================
 Package                   Arch                         Version                                 Repository                                Size
===============================================================================================================================================
Installing:
 zsh                       x86_64                       4.3.10-4.1.el6                          rhel-6-server-rpms                       2.1 M

Transaction Summary
===============================================================================================================================================
Install       1 Package(s)

Total download size: 2.1 M
Installed size: 2.1 M
Is this ok [y/N]: y
Downloading Packages:
zsh-4.3.10-4.1.el6.x86_64.rpm                                                                                           | 2.1 MB     00:02     
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing : zsh-4.3.10-4.1.el6.x86_64                                                                                                   1/1 
rhel-6-server-rpms/productid                                                                                            | 1.7 kB     00:00     
Installed products updated.

Installed:
  zsh.x86_64 0:4.3.10-4.1.el6                                                                                                                  

Complete!



^^^ Although harmless, the "duration" info which was being printed is no longer being printed.
moving to VERIFIED
Comment 7 errata-xmlrpc 2011-12-06 12:14:18 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1695.html

Note You need to log in before you can comment on or make changes to this bug.