Bug 7051 - ps reports wrong info when uptime greater than 249 days
Summary: ps reports wrong info when uptime greater than 249 days
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: procps (Show other bugs)
(Show other bugs)
Version: 5.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-11-16 19:01 UTC by Damon Gunther
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-09-22 12:41:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Damon Gunther 1999-11-16 19:01:46 UTC
For a 5.2 machine, ps output is has incorrect time/date info if the uptime
is over 249 days.  Any process started has the date of the 249th day
instead of the current time and processes started at boot have a time
instead of a date.

Here is the output from a box up 263 days:

uptime:
11:31am  up 263 days, 25 min, 14 users,  load average: 0.00, 0.00, 0.00

date:
Tue Nov 16 11:32:24 EST 1999

ps auxw:  (xterm just started)
root      2337  0.0  1.2  2436  1580  pb S   Nov  2   0:00 xterm

ps auxw: (for init)
root         1  0.0  0.0   776    68  ?  S    14:33   0:08 init

The behavior is also on a box that has been up for 323 days.

Comment 1 Michael K. Johnson 2000-07-31 20:08:31 UTC
Try upgrading procps -- see
ftp://people.redhat.com/johnsonm/procps/

Comment 2 Damon Gunther 2000-08-08 15:05:41 UTC
Unfortunately, I am unable to test this now.  The boxes that were up that long
have been rebooted.
The box that was up 323 days made it to 385 (yay!) and then was reinstalled with
6.1.  Currently,
it is working on 180 days, so I should see if the bug is gone in 2 months.  I
will let you know.

I am running procps 2.0.4.  I see 2.0.7 is at the FTP site you sent.  I will
wait to upgrade the package
until I reach ~249 days and then, if there is a problem, see if the update
works.

Damon

Comment 3 Damon Gunther 2000-09-22 12:41:29 UTC
That did it!  The 5.2 machine in question was running procps-1.2.9-2.
I built the 2.0.7 binaries and it displayed the correct dates in ps.  Thanks!
(Sadly, it won't matter much longer since the machine is going to 6.2 today. :)



Note You need to log in before you can comment on or make changes to this bug.