Bug 705317 - Failed to ping guest(rhel4.9) after change virtio MTU
Failed to ping guest(rhel4.9) after change virtio MTU
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.7
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Michael S. Tsirkin
Virtualization Bugs
:
Depends On:
Blocks: Rhel5KvmTier3
  Show dependency treegraph
 
Reported: 2011-05-17 07:05 EDT by Golita Yue
Modified: 2011-05-18 09:28 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-18 09:28:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Golita Yue 2011-05-17 07:05:48 EDT
Description of problem:
I booted up a rhel4.9 guest with virtio nic, change the MTU of guest nic and tap device to 65520 (max MTU of virtio nic), and added an arp entry on host, then ping guest from host, but it was failed.

Version-Release number of selected component (if applicable):
host:
kvm-83-232.el5
kernel 2.6.18-259.el5

guest(rhel4.9):
kernel 2.6.9-100.ELhugemem 
this problem happened in rhel4.9-32/64/PAE 

How reproducible:
100%

Steps to Reproduce:
1. boot guest with virtio nic by cmd

2. Change MTU of guest nic and $tap
guest)# ifconfig eth0 mtu 65520
host)# ifconfig $tap mtu 65520

3. Add a arp entry on host
# arp -s $guest_ip $guest_mac -i $tap

4. Ping guest from host  (65520-28=65492, 65520 is max mtu of virtio)
#ping $guest_ip -I $tap -s 65492 -M do
  
Actual results:
could not ping guest successfully

Expected results:
can ping guest successfully

Additional info:
cmd:
/usr/libexec/qemu-kvm -drive file='RHEL-4.9-PAE-virtio.raw',index=0,if=ide,media=disk,cache=none,format=raw -net nic,vlan=0,model=virtio,macaddr='9a:85:ef:26:a1:34' -net tap,vlan=0,ifname='t0-134629-2A7D',script='/etc/qemu-ifup-switch',downscript='no' -m 4096 -smp 
2,cores=1,threads=1,sockets=2 -cpu qemu64,+sse2 -soundhw ac97 -vnc :0 -rtc-td-hack -M rhel5.6.0 -boot c  -usbdevice tablet -no-kvm-pit-reinjection
Comment 3 Glauber Costa 2011-05-18 09:28:51 EDT
This is due to lack of jumbo frame support in RHEL4.
Due to schedule constraints, we don't plan to fix it.

For more information, see 633195, opened against 6.1

Note You need to log in before you can comment on or make changes to this bug.