Bug 70537 - Gnome panel intermittently disappears during login
Gnome panel intermittently disappears during login
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: gnome-session (Show other bugs)
limbo
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
:
Depends On:
Blocks: 67217
  Show dependency treegraph
 
Reported: 2002-08-02 06:37 EDT by Fred New
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-19 03:09:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fred New 2002-08-02 06:37:09 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.0.1) Gecko/20020724

Description of problem:
Sometimes when I logon to a Gnome session, there is no panel.

Version-Release number of selected component (if applicable):
gnome-panel-2.0.2.90-8
gnome-session-2.0.1-3


How reproducible:
Sometimes

Steps to Reproduce:
1.  Log onto Gnome.


	

Actual Results:  The desktop appears, but often, the panel is missing.

Expected Results:  A panel at the bottom of the desktop.

Additional info:

Possible contributing (old) platform factors:  75 MHz Pentium, 40 MB RAM, 128 MB
swap space, no sound card.
Comment 1 Havoc Pennington 2002-08-07 16:27:15 EDT
This does seem to be a race condition that's more common on slow machines.
Comment 2 Fred New 2002-08-09 07:31:53 EDT
I have updated to
  gnome-panel-2.0.3-3
  gnome-session-2.0.3-1
and the panel has appeared after all of 5 logins.

However, there have been other random problems like being unable to get a
response from right-clicking the background, the dragonfly failing to appear,
the desktop icons failing to appear, desktop icons overlapping (#68449), and the
following message window appearing once:

------------
There was an error starting the GNOME Settings Daemon.

Some things, such as themes, sounds, or background settings may not work correctly.

The Settings Daemon restarted too many times.

The last error message was:

Child process did not give an error message, unknown failure occurred

GNOME will still try to restart the Settings Daemon next time you log in.
------------

Given this information, I think it is safe to close this problem as a duplicate
of one of the other "race condition" bugs.

Comment 3 Havoc Pennington 2002-08-14 01:34:18 EDT
Turns out the default session file was mangled. Try with gnome-session 2.0.5-2
Comment 4 Fred New 2002-08-19 03:09:13 EDT
I have been using gnome-panel-2.0.3-3 and gnome-session-2.0.5-3 since Thursday
and I haven't seen gnome panel disappear in all that time.  I have seen the
Gnome settings daemon error several times, but this problem is probably beyond
the scope of this bug.
Comment 5 Jay Turner 2002-08-30 13:19:52 EDT
Closing this out as the user is reporting the issue resolved.

Note You need to log in before you can comment on or make changes to this bug.