Bug 70575 - reading certain email crashes pine
reading certain email crashes pine
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: pine (Show other bugs)
7.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-02 13:43 EDT by Need Real Name
Modified: 2007-04-18 12:45 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-08 04:59:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-08-02 13:43:22 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020606

Description of problem:
There's output in an email generated by logwatch that crashes pine when i read
it. Pine dies with the following error:

Problem detected: "Received abort signal".
Pine Exiting.
[jon@opiate mail]$ 

The problem seems to lie in the following line(s):

      1     5651   euro.com
      1   %$#^%@euro.com
   5651   %$#^%@euro.com

although not reading them in the context of the whole email doesn't seem to
crash pine.

I'm using pine-4.44-1.72.0.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. read this particular email
2. pine crashes

	

Actual Results:  Problem detected: "Received abort signal".
Pine Exiting.
[jon@opiate mail]$ 

Expected Results:  i should have been able to continue reading email :-)

Additional info:

since the email is from my logwatch script, and since it contains mail records,
i'd prefer not to attach it to this bug. is there a particular person i can
email it to instead? (i'm paranoid about having a day's worth of mail logs +
tripwire results + etc anywhere that google can get them).
Comment 1 Mike A. Harris 2002-08-08 04:58:57 EDT
Can you produce an email message which also causes pine to die without
having sensitive material in it?  I'm going to need a valid test case,
which can be attached to the bug report, since many people may need
to view it, and the issue may not be resolved immediately.  We need
to keep everything pertaining to a bug in one place.

I also recommend reporting this problem directly to the PINE team, to
ensure it is fixed in the next release of PINE.
Comment 2 Mike A. Harris 2002-09-05 03:12:15 EDT
Without a bug test case with which to reproduce this problem, and
then run pine in a debugger to determine where it is failing, there
is nothing I can do to troubleshoot it.

Closing bug WONTFIX, as it isn't possible to fix an unreproduceable
bug without data.  Please feel free to reopen once data is obtained
that can be attached to the bug report.

Note You need to log in before you can comment on or make changes to this bug.