Bug 7058 - wrong directory permissions with squid
Summary: wrong directory permissions with squid
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: squid   
(Show other bugs)
Version: 6.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-11-16 21:33 UTC by mike
Modified: 2014-03-17 02:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-12-21 19:19:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description mike 1999-11-16 21:33:00 UTC
I recently installed squid on a RH6.1 server from the rpm on the CD. It
installed into /usr/lib/squid (Which I think is a really dumb place for it,
but anyway). The owner/group by default is root/root. But squid runs as
nobody, so it cannot create the cache directories on the first run. I did
notice this in an earlier version squid (not installed by RPM) so maybe it
is their problem, and not yours. Just thought I would mention it.

Mike

Comment 1 Bill Nottingham 1999-12-21 19:19:59 UTC
The default cache_dir is /var/spool/squid, which
is owned by user squid/squid. I can't reproduce
your problem here.


Note You need to log in before you can comment on or make changes to this bug.