Bug 70582 - can't double-click last visible file in file upload dialog
Summary: can't double-click last visible file in file upload dialog
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: mozilla   
(Show other bugs)
Version: limbo
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Christopher Blizzard
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-08-02 19:16 UTC by Kris Urquhart
Modified: 2007-04-18 16:45 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-02 19:20:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Kris Urquhart 2002-08-02 19:16:15 UTC
Description of Problem:
I found this while trying to add an attachment to a bugzilla.  While browsing, I
visited a directory that had many files in it, but the one I wanted was the last
one visible in the dialog (but not the last file in the directory).  When I went
to double-click on it, the first click caused the list to scroll up one line,
and so did the second click.  Double-clicking on files in the middle of the list
works fine.

Version-Release number of selected component (if applicable):
mozilla-1.0.1-10


How Reproducible:
Very

Steps to Reproduce:
1. start to attach a file to a bugzilla
2. browse to a directory that has lots of files in it
3. try to double-click on the last file visible in the list (but not the last
file in the directory)

Actual Results:
list scrolls up two lines

Expected Results:
double-clicking should select the desired file

Additional Information:
screen resolution 1152x864
stock fonts

Comment 1 Kris Urquhart 2002-08-02 19:20:35 UTC
The actual results are even worse - the file two lines down is selected.  In my
case, I am in /var, and trying to select "log", but the list scrolls down two
and then descends into "mail".


Comment 2 Christopher Blizzard 2002-08-30 14:41:48 UTC
Works for me in 1.0.1-23.

Comment 3 Kris Urquhart 2002-08-31 00:28:04 UTC
I agree it now works fine, thanks!


Note You need to log in before you can comment on or make changes to this bug.