Bug 705952 - libnfsidmap fails to include ldap support
libnfsidmap fails to include ldap support
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libnfsidmap (Show other bugs)
15
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Steve Dickson
Fedora Extras Quality Assurance
:
: 692675 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-18 19:56 EDT by friedman
Modified: 2012-11-21 05:16 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-19 20:27:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Revised rpm patch to include config.h in umich_ldap.c (3.99 KB, patch)
2011-05-18 19:56 EDT, friedman
no flags Details | Diff

  None (edit)
Description friedman 2011-05-18 19:56:42 EDT
Created attachment 499725 [details]
Revised rpm patch to include config.h in umich_ldap.c

The patch currently applied to libnfsidmap-0.24-5.fc15 includes a change to configure.in which generates a config.h file.  umich_ldap.c is not presently including that file and as a consequence (because -DENABLE_LDAP is no longer passed on the command line), does not actually provide any ldap backend support.

I've generated a new patch which should be equivalent to libnfsidmap-0-25-rc1.patch other than adding the appropriate include in umich_ldap.c.
Comment 1 friedman 2012-02-09 14:28:21 EST
Still broken in Fedora 16.  umich_ldap.c just needs to include config.h at the top.
Comment 2 Steve Dickson 2012-03-13 15:43:07 EDT
*** Bug 692675 has been marked as a duplicate of this bug. ***
Comment 3 Fedora Update System 2012-03-13 15:49:01 EDT
libnfsidmap-0.24-6.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/libnfsidmap-0.24-6.fc15
Comment 4 Fedora Update System 2012-05-18 06:37:21 EDT
Package libnfsidmap-0.24-6.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libnfsidmap-0.24-6.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-8066/libnfsidmap-0.24-6.fc15
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2012-06-19 20:27:31 EDT
libnfsidmap-0.24-6.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 friedman 2012-07-03 16:05:11 EDT
It's still broken in Fedora 17.
Comment 7 ernest.beinrohr 2012-11-21 05:16:48 EST
i am too affected by this in FC17.

Note You need to log in before you can comment on or make changes to this bug.