Bug 706035 - Using Cyrillic letter cause ISE
Using Cyrillic letter cause ISE
Status: CLOSED DUPLICATE of bug 659138
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
541
Unspecified Unspecified
medium Severity low
: ---
: ---
Assigned To: Tomas Lestach
Red Hat Satellite QA List
:
Depends On:
Blocks: sat541-triage
  Show dependency treegraph
 
Reported: 2011-05-19 05:10 EDT by Dimitar Yordanov
Modified: 2012-03-08 04:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-20 14:20:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dimitar Yordanov 2011-05-19 05:10:31 EDT
Description of problem:
Using Cyrillic letter cause ISE 

Version-Release number of selected component (if applicable):
Satellite-541, RHEL6
spacewalk-java-1.2.39-77.el6sat.noarch


How reproducible:
Always

Steps to Reproduce:
1. Admin -> Task Schedules -> Create New Schedule
2. Schedule name*: Червената–шапчица
3. Choose some timing
4. Press "Create Schedule"
  
error Internal Server Error

The server experienced a problem which prevented your request from being filled out. It may not be possible to execute this action at this time.

Please help us correct this problem by contacting us with details of how you received this messag

5.Choose "Task Schedule" from the menu on the left.
6. You can see that New Schedule is created but the name is '????????????????'
7. Choose the new created Schedule 
8.  Press : "delete schedule"
9.  Press : "Delete schedule" again

Actual results:
Error:
The scheduling service appears down. Please contact your Satellite administrator.

[root@abc]# ps -ef | grep -i /usr/bin/taskomaticd 
root     26497     1  0 07:44 ?        00:00:00 /usr/bin/taskomaticd /etc/rhn/default/rhn_taskomatic_daemon.conf wrapper.pidfile=/var/run//taskomatic.pid wrapper.daemonize=TRUE


Expected results:
Appropriate behavior

Additional info:
Comment 1 Tomas Lestach 2011-05-19 13:04:48 EDT
The issue seems to be visible only on RHEL6 (not on RHEL5).
Comment 2 Tomas Lestach 2011-05-20 14:20:21 EDT
I restricted schedule names similar to channel labels (no special characters allowed).

Since the fix is within a new feature, I close this bug as duplicate and fix the issue within the original RFE BZ.

https://bugzilla.redhat.com/show_bug.cgi?id=659138#c22

*** This bug has been marked as a duplicate of bug 659138 ***

Note You need to log in before you can comment on or make changes to this bug.