Bug 706066 - OpenJDK fails to compile commons-discovery 0.5
Summary: OpenJDK fails to compile commons-discovery 0.5
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: java-1.6.0-openjdk
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Denis Lila
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 701253
TreeView+ depends on / blocked
 
Reported: 2011-05-19 11:43 UTC by Stanislav Ochotnicky
Modified: 2011-06-01 20:52 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-06-01 20:52:01 UTC
Type: ---


Attachments (Terms of Use)
build log from commons-discovery compilation (6.25 KB, text/plain)
2011-05-19 11:43 UTC, Stanislav Ochotnicky
no flags Details

Description Stanislav Ochotnicky 2011-05-19 11:43:12 UTC
Created attachment 499817 [details]
build log from commons-discovery compilation

Description of problem:
Trying to use OpenJDK to compile commons-discovery fails with compilation failures due to generics. Oracle SDK works OK.  Build log attached

Can reproduce in rawhide too.

Version-Release number of selected component (if applicable):
java-1.6.0-openjdk-1.6.0.0-52.1.9.7.fc14.x86_64

How reproducible:
always

Steps to Reproduce:
1. download comons-discovery source[1], unpack
2. install "maven" package
3. run "mvn3 compile"

[1] http://archive.apache.org/dist/commons/discovery/source/commons-discovery-0.5-src.tar.gz
  
Actual results:
compilation failure, see build log

Expected results:
build success

Comment 1 Denis Lila 2011-06-01 18:41:21 UTC
Hi Stanislav.

I've proposed this fix for the bug:
http://mail.openjdk.java.net/pipermail/distro-pkg-dev/2011-June/014574.html

I tested it, and it does fix the compilation problem, but as Andrew Haley rightly pointed out, such compiler changes are very dangerous. I also submitted a patch to the discovery project that works around the compiler bug, and hopefully they will include it in their project.

Comment 2 Denis Lila 2011-06-01 20:52:01 UTC
Hi again.

commons-discovery has accepted my patch, so I am closing this as wont-fix for now. If this compilation problem comes up with some other project, we can reconsider the backport.


Note You need to log in before you can comment on or make changes to this bug.