This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 70611 - Aggrivating version numbers
Aggrivating version numbers
Status: CLOSED NOTABUG
Product: Red Hat Public Beta
Classification: Retired
Component: glibc (Show other bugs)
limbo
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-02 16:50 EDT by Valdis Kletnieks
Modified: 2016-11-24 09:56 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-02 16:51:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Valdis Kletnieks 2002-08-02 16:50:58 EDT
Description of Problem:
Problematic RPM numbers for 'rpm -F'

Version-Release number of selected component (if applicable):
glibc-2.2.90-17.i686.rpm

How Reproducible:


Steps to Reproduce:
1. 
2. 
3. 

Actual Results:
Whenever glibc-2.2.6 comes out, 'rpm -F' will refuse to install it because .90
is bigger than .6

Expected Results:


Additional Information:
I've gotten bit by this on RawHide before - something will use 2.8.3, then
2.8.94, then when 2.8.4 comes out you have a headache in upgrading.  Wouldn't
'glib-2.2.5-90.17' have worked just as well?
Comment 1 Jeremy Katz 2002-08-03 16:35:35 EDT
glibc 2.2.90 is CVS glibc 2.3, so it is newer than glibc 2.2.6

Note You need to log in before you can comment on or make changes to this bug.