Bug 70613 - rpm-4.1-0.63 appears to be broken
rpm-4.1-0.63 appears to be broken
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: rpm (Show other bugs)
1.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-02 16:58 EDT by Alexander Farley
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-02 16:58:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Farley 2002-08-02 16:58:05 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020724

Description of problem:
rpm-4.1-0.63 (and 0.62) packages appear to be broken. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Upgrade to the current (4.1-0.63) packages
2.try to use the new packages.
3.
	

Actual Results:  Rpm system becomes completely broken (i.e. refueses to install
new packages and gives odd messages with rpm -Va)

Expected Results:  Rpm would work.

Additional info:

Several different error messages are generated:
When a new package is installed rpm reports that "the package is designed for an
i386 or alternatively a noarch architecture" (I am pretty sure that my
architecture (Athlon/i686) is i386 compatible and I am definitely sure that my
system is noarch compatible.
When the rpm database is verified using rpm -Va many packages give a message
like warning: The :B: dependency needs an epoch (assuming same epoch as "A")
A = "gtk+ 1:1.2.10-21"   B = "gtk+ >= 1.2.5"

I solved the problem by compiling 4.1-0.53 from source and and installing.  I am
pretty sure that this is not a very useful work around, especially since the 4.1
source was no so easy to come by without copying it from a source rpm installed
on another machine (running 4.1-0.53).
Comment 1 Jeff Johnson 2002-08-02 17:00:59 EDT
Alread fixed, an athlon with CMOV misidentifies as
i786.

Note You need to log in before you can comment on or make changes to this bug.