Bug 706138 - /etc/shells should contain dash
Summary: /etc/shells should contain dash
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dash
Version: 14
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Petr Šabata
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 706147
TreeView+ depends on / blocked
 
Reported: 2011-05-19 15:28 UTC by Petr Šabata
Modified: 2011-06-26 18:52 UTC (History)
5 users (show)

Fixed In Version: dash-0.5.6-4.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 706147 (view as bug list)
Environment:
Last Closed: 2011-05-25 18:54:17 UTC


Attachments (Terms of Use)

Description Petr Šabata 2011-05-19 15:28:55 UTC
Description of problem:
Users can't use dash as their shell since it's not present in the /etc/shells file.

Version-Release number of selected component (if applicable):
0.5.6-3

How reproducible:
Always.

Steps to Reproduce:
1. Install dash.
2. Try to set dash as your shell (e.g. via chsh)
  
Actual results:
chsh: "/bin/dash" is not listed in /etc/shells.

Expected results:
Shell changed.

Additional info:
This can be solved via %post and %postun scriptlets.

Comment 1 Petr Šabata 2011-05-19 15:30:06 UTC
%post
if [ $1 -eq 1 ]; then
    grep -qF /bin/dash /etc/shells || echo '/bin/dash' >> /etc/shells
fi

%postun
if [ $1 -eq 0 ]; then
    sed -i '/\/bin\/dash/d' /etc/shells
fi

Comment 2 Fedora Update System 2011-05-19 15:48:05 UTC
dash-0.5.6-3.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/dash-0.5.6-3.fc14

Comment 3 Fedora Update System 2011-05-19 15:48:45 UTC
dash-0.5.6-4.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/dash-0.5.6-4.fc15

Comment 4 Fedora Update System 2011-05-19 21:58:10 UTC
Package dash-0.5.6-4.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dash-0.5.6-4.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/dash-0.5.6-4.fc15
then log in and leave karma (feedback).

Comment 5 Othman Madjoudj 2011-05-20 20:39:01 UTC
dash-0.5.6-4.fc15 update has not yet fixed this issue on Fedora 15:

~]$ rpm -q dash
dash-0.5.6-4.fc15.i686

~]$ cat /etc/shells 
/bin/sh
/bin/bash
/sbin/nologin

Comment 6 Andre Robatino 2011-05-22 02:55:53 UTC
Not fixed on F14 either, with dash-0.5.6-3.fc14.x86_64 installed.

Comment 7 Petr Šabata 2011-05-23 06:26:43 UTC
This only applies to new installations, not upgrades.

I understand that's not really convenient. A new update is on its way...

Comment 8 Fedora Update System 2011-05-23 07:19:53 UTC
dash-0.5.6-4.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/dash-0.5.6-4.fc14

Comment 9 Fedora Update System 2011-05-23 07:20:14 UTC
dash-0.5.6-5.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/dash-0.5.6-5.fc15

Comment 10 Othman Madjoudj 2011-05-23 07:47:07 UTC
Seems to be fixed on f15:

$ cat /etc/shells
/bin/sh
/bin/bash
/sbin/nologin
/bin/dash

Comment 11 Fedora Update System 2011-05-25 02:23:05 UTC
Package dash-0.5.6-4.fc14:
* should fix your issue,
* was pushed to the Fedora 14 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dash-0.5.6-4.fc14'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/dash-0.5.6-4.fc14
then log in and leave karma (feedback).

Comment 12 Fedora Update System 2011-05-25 18:54:12 UTC
dash-0.5.6-5.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2011-06-26 18:51:56 UTC
dash-0.5.6-4.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.