Bug 70623 - kiobuf->map_array has dissapeared from kernel 2.4.18-5
kiobuf->map_array has dissapeared from kernel 2.4.18-5
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-02 17:46 EDT by Peter W
Modified: 2007-04-18 12:45 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-02 17:46:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter W 2002-08-02 17:46:15 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020513

Description of problem:
The file /usr/src/linux-2.4/include/linux/iobuf.h has been changed between
2.4.18-3 and 2.4.18-5 and one of the members of the struct kiobuf (map_array)
has been removed (look at both files near line 53).  Since it hasn't been
removed from the linux 2.4.19 I assume this was a mistake.  It has also been
removed from linux-2.4/fs/iobuf.c.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install RedHat 7.3.
2.Use up2date to upgrade to kernel 2.4.18-5 (from default 2.4.18-3).
3.Notice that "map_array" is gone from
/usr/src/linux-2.4.18-5/include/linux/iobuf.h. (it *was* in corresponding
2.4.18-3 file).
	

Actual Results:  map_array is gone.

Expected Results:  map_array should not be gone. 

Additional info:
Comment 1 Arjan van de Ven 2002-08-03 05:15:59 EDT
the recoding of the kiobuff is actually a performance enhancement (the kiobufs
become leaner and use less memory/cache)

Note You need to log in before you can comment on or make changes to this bug.