This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 706253 - python 2.7 doesn't compile on F-14 on arm 5tel due to test_float failure
python 2.7 doesn't compile on F-14 on arm 5tel due to test_float failure
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: python (Show other bugs)
14
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dave Malcolm
Fedora Extras Quality Assurance
:
Depends On:
Blocks: ARMTracker
  Show dependency treegraph
 
Reported: 2011-05-19 16:56 EDT by Peter Robinson
Modified: 2011-08-06 14:32 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-23 14:04:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Peter Robinson 2011-05-19 16:56:16 EDT
When compiling the python that shipped with F-14 (with a a slightly updated spec for valgrind exclusion) we get a test failure in the test_float

The full build logs are available here:
http://arm.koji.fedoraproject.org/koji/getfile?taskID=94277&name=build.log

It looks like this bug here:
http://bugs.python.org/issue8265

If this isn't fixable is it possible to get the test disabled, either for all build or with an exception for the arm platform.

As a side node the current release in fedora 14 mainline x86 has a test ioctl failure (only change on this build was the arm exclude).
http://koji.fedoraproject.org/koji/getfile?taskID=3078441&name=build.log
Comment 1 Dave Malcolm 2011-05-23 13:52:18 EDT
Thanks for looking into this.

I see you fixed this in git with:
http://pkgs.fedoraproject.org/gitweb/?p=python.git;a=commitdiff;h=599d1aa47d600dd4f01f6518fb1c712602723cef

and similar commits to f14 and f15

Koji builds are here:

  python-2.7.1-8.fc16:
    http://koji.fedoraproject.org/koji/buildinfo?buildID=244838

  python-2.7.1-8.fc15:
    http://koji.fedoraproject.org/koji/buildinfo?buildID=244853

  python-2.7-8.fc14.4:
    http://koji.fedoraproject.org/koji/buildinfo?buildID=244297

Does anything further need to happen before this bug can be closed?
Comment 2 Peter Robinson 2011-05-23 14:04:10 EDT
Nope. We're all good. Fixed in rawhide/F-15/F-14

Note You need to log in before you can comment on or make changes to this bug.