Bug 70630 - xitk_image_create_image: Assertion `im && width && height' failed.
xitk_image_create_image: Assertion `im && width && height' failed.
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: xine (Show other bugs)
8.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: wdovlrrw
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-02 18:16 EDT by Pawel Salek
Modified: 2007-04-18 12:45 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-27 08:49:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pawel Salek 2002-08-02 18:16:10 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020724

Description of problem:
Start xine without arguments and watch it fail.

Version-Release number of selected component (if applicable):
xine-0.9.9-5


How reproducible:
Always

Steps to Reproduce:
1. type xine at command prompt

Actual Results:  Found xine library version: 0.9.9 (0.9.9).
Display is not using Xinerama.
configfile: error - tried to update unknown key video.logo_file (to
/usr/share/xine/skins/xine_logo.zyuy2)
[New Thread 2049 (LWP 8570)]
[New Thread 1026 (LWP 8571)]
main: probing <Xv> video output plugin
video_out_xv: using Xv port 59 from adaptor ATI Radeon Video Overlay for
hardware colorspace conversion and scaling.
video_out_xv: port attribute XV_COLORKEY value is 0
video_out_xv: port attribute XV_BRIGHTNESS value is 0
video_out_xv: port attribute XV_SATURATION value is 16
video_out_xv: double buffering mode = 1
video_out_xv: this adaptor supports the yuy2 format.
video_out_xv: this adaptor supports the yv12 format.
load_plugins: video output plugin Xv successfully loaded.
main: probing audio drivers...
main: trying to autoload 'oss' audio driver: audio_oss_out: Opening audio device...
audio_oss_out: using device >/dev/dsp<
audio_oss_out: using SNDCTL_DSP_GETODELAY
audio_oss_out : supported modes are stereo
load_plugins: audio output plugin oss successfully loaded.
main: ...worked, using 'oss' audio driver.
xine: xine_init entered
Benchmarking memcpy methods (smaller is better):
        glibc memcpy() : 589461587
        linux kernel memcpy() : 569316778
        MMX optimized memcpy() : 777579864
        MMXEXT optimized memcpy() : 381154039
        SSE optimized memcpy() : 437822245
xine: using MMXEXT optimized memcpy()
xine-scr_init: complete
[New Thread 2051 (LWP 8574)]
load_plugins: input plugin found : CDA
load_plugins: input plugin found : DVD
load_plugins: input plugin found : file
load_plugins: input plugin found : HTTP
load_plugins: input plugin found : MMS
load_plugins: input plugin found : TCP
load_plugins: input plugin found : RTP
load_plugins: input plugin found : stdin_fifo
load_plugins: input plugin found : VCD
load_plugins: demux plugin found : AVI
load_plugins: demux plugin found : CDA
load_plugins: demux plugin found : MPEG
load_plugins: demux plugin found : MPGAUDIO
load_plugins: demux plugin found : MPEG_BLOCK
load_plugins: demux plugin found : MPEG_ELEM
load_plugins: demux plugin found : MPEG_PES
load_plugins: demux plugin found : MPEG_TS
load_plugins: demux plugin found : OGG
load_plugins: demux plugin found : QUICKTIME
audio decoder plugin found : a/52dec
audio decoder plugin found : dts
libavcodec: CPU flags: mmx mmxext sse
video decoder plugin found : ffmpeg video decoder
audio decoder plugin found : lpcm
audio decoder plugin found : mad
video decoder plugin found : mpeg2dec
spu decoder plugin found : spudec
spu decoder plugin found : spucc
spu decoder plugin found : sputext
audio decoder plugin found : vorbis
video decoder plugin found : vfw (win32) video decoder
audio decoder plugin found : vfw (win32) audio decoder
[New Thread 3076 (LWP 8575)]
video_out: copying logo image
video_out: thread created
[New Thread 4101 (LWP 8576)]
[New Thread 5126 (LWP 8577)]
metronom: start_clock (at 0)
xine: image.c:204: xitk_image_create_image: Assertion `im && width && height'
failed.
(gdb) where
#4  0x0807d2ef in xitk_image_create_image ()
#5  0x08097abc in tabs_arrange ()
#6  0x08097d6a in paint ()
#7  0x0809240e in xitk_paint_widget_list ()
#8  0x08068145 in setup_paint_widgets ()
#9  0x08067ba8 in setup_panel ()
#10 0x08061564 in gui_setup_show ()
#11 0x08051045 in gui_execute_action_id ()
#12 0x08051e09 in gui_run ()
#13 0x080501ba in main ()


Expected Results:  xine should start.

Additional info:

I wonder whether it is related to the fact that xinerama is absent (I am just
clutching at straws). The graphics card is Radeon Mobility
Comment 1 Karsten Hopp 2004-01-27 08:49:31 EST
xine isn't part of any supported product from Red Hat anymore

Note You need to log in before you can comment on or make changes to this bug.