Bug 706334 - Win7 guest cannot be saved on KVM hypervisor
Win7 guest cannot be saved on KVM hypervisor
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: libvirt (Show other bugs)
5.7
x86_64 Linux
high Severity high
: rc
: ---
Assigned To: Eric Blake
Virtualization Bugs
:
Depends On:
Blocks: Rhel5KvmTier1
  Show dependency treegraph
 
Reported: 2011-05-20 03:05 EDT by mliu
Modified: 2013-01-09 18:53 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-15 17:45:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mliu 2011-05-20 03:05:25 EDT
Description of problem:
Win7 guest cannot be saved on KVM hypervisor

Version-Release number of selected component (if applicable):
kernel-2.6.18-262.el5
virt-manager-0.6.1-14.el5
libvirt-0.8.2-20.el5
kvm-qemu-img-83-232.el5

How reproducible:
Always

Steps to Reproduce:
1. Install win7 guest on real disk, here is /dev/sda3
2. Open the win7 detail window, on the menu list, select "Virtual Machine" and click "Save"
3. Input the name and click "Save"
  
Actual results:
Error saving domain: operation failed: migration to 'exec:cat | { dd bs=4096 seek=1 if=/dev/null && dd bs=1048576; } 1<>/var/lib/libvirt/win7' failed: migration failed

Expected results:
the guest can be saved successfully.

Additional info:

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/engine.py", line 435, in _save_callback
    vm.save(file_to_save)
  File "/usr/share/virt-manager/virtManager/domain.py", line 597, in save
    vm.save(filename)
  File "/usr/lib64/python2.4/site-packages/libvirt.py", line 608, in save
    if ret == -1: raise libvirtError ('virDomainSave() failed', dom=self)
libvirtError: operation failed: migration to 'exec:cat | { dd bs=4096 seek=1 if=/dev/null && dd bs=1048576; } 1<>/var/lib/libvirt/win7' failed: migration failed
Comment 1 RHEL Product and Program Management 2011-06-21 01:29:41 EDT
This request was evaluated by Red Hat Product Management for inclusion in Red Hat Enterprise Linux 5.7 and Red Hat does not plan to fix this issue the currently developed update.

Contact your manager or support representative in case you need to escalate this bug.
Comment 3 Dor Laor 2011-08-07 06:50:21 EDT
Can't be a qemu bug since the save part fails w/o even a restore.
Comment 4 RHEL Product and Program Management 2011-08-15 17:45:07 EDT
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.