Bug 706347 - nss 3.12.10 doesn't build on ARMv5tel platforms
nss 3.12.10 doesn't build on ARMv5tel platforms
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: nss (Show other bugs)
14
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Elio Maldonado Batiz
Fedora Extras Quality Assurance
:
Depends On:
Blocks: ARMTracker
  Show dependency treegraph
 
Reported: 2011-05-20 04:02 EDT by Peter Robinson
Modified: 2011-08-06 14:32 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-23 14:09:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Disable the ssl tests suites on arm platform. (2.05 KB, patch)
2011-05-23 15:08 EDT, Elio Maldonado Batiz
no flags Details | Diff

  None (edit)
Description Peter Robinson 2011-05-20 04:02:10 EDT
The latest version of nss doesn't build on ARM platforms. It fails a couple of tests (minor details below). nss-util and nss-softokn build without issues. 

The full chain build of the latest nspr/nss-util/nss-softokn/nss can be found here
http://arm.koji.fedoraproject.org/koji/taskinfo?taskID=94426

Tests summary:
--------------
Passed:             3698
Failed:             8
Failed with core:   0
Unknown status:     0
+ cd ../../../../
+ killall selfserv_9936
selfserv_9936: no process killed
+ :
++ grep -c FAILED ./mozilla/tests_results/security/localhost.1/output.log
error: test suite returned failure(s)
+ TEST_FAILURES=12
+ '[' 12 -ne 0 ']'
+ echo 'error: test suite returned failure(s)'
+ exit 1
Comment 1 Peter Robinson 2011-05-23 14:09:08 EDT
We fixed this in F-14/F15/rawhide by disabling tests for ARM.
Comment 2 Elio Maldonado Batiz 2011-05-23 15:04:51 EDT
The test that fail are ssl tests where client times attempinting a connection to the local test server on system with dual ipv6/ipv4 stack. This is related to Bug 539183 for which we had applied an upstream short-term fix for use in Linux and Mac OS X builds and testing, see 
https://bugzilla.mozilla.org/show_bug.cgi?id=617723. Unfortunately, it's not working on arm. Until the problem is fixed we could just opt to disable only the ssl tests.
Comment 3 Elio Maldonado Batiz 2011-05-23 15:08:34 EDT
Created attachment 500487 [details]
Disable the ssl tests suites on arm platform.

Suggested modifications to nss.spec file in the for of a patch to disable only the ssl tests.

Note You need to log in before you can comment on or make changes to this bug.