Bug 70637 - cannot show japanese character
cannot show japanese character
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: less (Show other bugs)
7.3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Karsten Hopp
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-02 19:14 EDT by Need Real Name
Modified: 2007-04-18 12:45 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-18 03:11:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-08-02 19:14:38 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; Q312461)

Description of problem:
SRPM includes i18n patch(ex: less-358+iso247-20001210.diff).
But it is not applied.
For that reason, less cannot show japanese character.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. make a japanese text file.
2. show it by less on kterm. 

	

Additional info:
Comment 1 Karsten Hopp 2002-08-02 19:29:31 EDT
The i18n patch isn't necessary anymore, the multibyte patch adds 
the same functionality and doesn't break support for western languages 
(which the i18n patch does!). 
 
Although I can't read japanese texts, I tried to compare the less output 
with the webbrowser output of the same file and it looks ok to me. 
 
Can you please attach a sample japanese text file which doesn't display 
properly ?
Comment 2 Need Real Name 2002-08-02 20:06:53 EDT
Ok. I'll send japanese text to you in E-mail.

By the way, less-358-28 on RawHide can show japanese character.
Because, This is applied "Patch2: less-358-iso254.patch and others".
Why is less-358-28 moved to updates?
Comment 3 Karsten Hopp 2002-08-03 07:52:55 EDT
I have disabled the less-358+iso247-20001210.diff patch in the 7.3 package 
because it breaks a lot of other languages. 
I added the iso254 and the -mf patch to the rawhide package to get feedback 
from users if it works now (such as your comment above). 
Now that I have confirmation that it actually works, I'm going to release  
an update package for 7.3 soon.
Comment 4 Akira 2002-08-18 03:11:01 EDT
From: "Kumakiri, Akira" <kumakiri@ekuma.com>
To: <valhalla-list@redhat.com>
Sent: Wednesday, September 18, 2002 2:41 PM
Subject: less can not display japanese character on RH7.3


less on RedHat 7.3 can not display Japanese character.

You can see UNIX USER<CA><D4><BD><B8><C9><F4>
<C6><FC>...bra, bra, when trying to type UNIX USER and following some Japanese
characters.

This caused by not using Japanese patch.  You can rebuild less-358-24.src.rpm 
by the
following procedure.

1) get less-358-24.src.rpm from 
ftp.redhat.com/pub/redhat/linux/7.3/en/os/i386/SRPMS
2) change to root
3) cd /usr/src/redhat/SPECS
4) cp less.spec less.spec.org  -- just for saving original
5) vi less.spec
    and remove # on the following lines.
%prep
%setup -q
%patch -p1 -b .bug
#%patch2 -p1 -b .i18n  <-- remove # here
%patch3 -p1 -b .eline
#%patch4 -p1 -b .chset <-- remoce # here
#%patch5 -p1 -b .rh <-- remove # here
#%patch6 -p1 -b .num <-- remove # here

6) rpm -ba less.spec
7) You can find rebuilt less-358-24.i386.rpm on /usr/src/redhat/RPMS/i386
8) rpm -ivh --force less-358-24.i386.rpm
9) check less command wether Japanese are typed correctly or not.
10) if OK, that's it !  if not, go back to step 4) and check less.spec vs.
less.spec.org

The above information is reported on http://www.unixuser.jp/info/ (Japanese) and
translate by me for those who is fighting for the same problem.  Hope this 
information
helps releasing patched version of less for Japanese on comming release.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.