Bug 70638 - "Starwars" screensaver locks up computer
"Starwars" screensaver locks up computer
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
:
Depends On:
Blocks: screensaver
  Show dependency treegraph
 
Reported: 2002-08-02 19:17 EDT by Marc Deslauriers
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-15 06:42:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marc Deslauriers 2002-08-02 19:17:50 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020724

Description of problem:
The "starwars" screensaver locks up my computer hard when I try and exit it. A
hardware reset is necessary. All other screensavers work fine.

Version-Release number of selected component (if applicable):
xscreensaver-4.05-2

How reproducible:
Always

Steps to Reproduce:
1.Preview "starwars" screensaver
2.Read a bit of the kernel readme
3.Press esc and BAM!
	

Actual Results:  Computer locks up

Expected Results:  Back to my desktop...

Additional info:

I made sure the file was not corrupt with rpm -V. All the other screensavers
work fine. "Starwars" is in the default "Random" screensaver group, so if it's
iffy, maybe it should be disabled...
Comment 1 Bill Nottingham 2002-08-12 15:37:32 EDT
What sort of video card do you have?
Comment 2 Marc Deslauriers 2002-08-12 18:21:32 EDT
I had a Matrox G200 when I opened this bug report. I know have a ATI Radeon
7000, and that screensaver does not lock up on me anymore.
Comment 3 Mike A. Harris 2002-08-22 11:03:52 EDT
Tim Smith has found a bug in the DRI locking which is believed to account
for this.  We may have a test fix soon.
Comment 4 Josiah Royse 2002-08-23 12:05:28 EDT
Also locks up on an ATI 7500 Radeon VE:

(II) RADEON(0): Primary V_BIOS segment is: 0xc000
(--) RADEON(0): Chipset: "ATI Radeon VE QY (AGP)" (ChipID = 0x5159)
(--) RADEON(0): Linear framebuffer at 0xc0000000
(--) RADEON(0): MMIO registers at 0xcfef0000
(--) RADEON(0): BIOS at 0xcfec0000
(--) RADEON(0): VideoRAM: 65536 kByte (64-bit SDR SDRAM)
Comment 5 Marc Deslauriers 2002-08-25 15:57:45 EDT
Well, this just locked up on me with my Radeon 7000, so I'll be able to test it
after all...
Comment 6 Thais Smith 2002-08-27 05:49:11 EDT
It'll lock up on *every* card that uses the DRI. To provoke it reliably, crank 
the rotation/speed etc. sliders for the "starwars" screensaver to maximum 
using xscreensaver-demo.
Comment 7 Mike A. Harris 2002-09-12 00:41:14 EDT
This problem is believed to be fixed now, and affected pretty much
all DRI enabled drivers.  Please test the latest rawhide X and
kernel either using the Red Hat Linux (Null) beta, or once the new
release of Red Hat Linux is completed and released.  After testing
this out with our latest kernel/X, please provide updated status, and
if the problem persists, please attach your X server log and config
file.

Most likely however, the problem will not occur in the lastest
packages.


Comment 8 Mike A. Harris 2003-01-15 06:42:50 EST
Closing as fixed in RAWHIDE, as no users have reported the problem
persisting for quite some time now since the packages have been updated.

Note You need to log in before you can comment on or make changes to this bug.