Bug 706384 - Traceback displayed while loding 2 instance of subscription-manager-gui
Traceback displayed while loding 2 instance of subscription-manager-gui
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 6.2
Assigned To: Bryan Kearney
John Sefler
:
Depends On:
Blocks: rhsm-rhel62
  Show dependency treegraph
 
Reported: 2011-05-20 06:53 EDT by spandey
Modified: 2015-04-23 19:56 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-06 12:14:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description spandey 2011-05-20 06:53:06 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
3/3

Prerequisites:

Client : Rhel5.7 client with following subscription-manager rpm 
subscription-manager-0.95.5.18-1.git.4.364aa10.el5

subscription-manager-gnome-0.95.5.18-1.git.4.364aa10.el5

subscription-manager-firstboot-0.95.5.18-1.git.4.364aa10.el5
 


Steps to repro : 

1) Invoke subscription-manager-gui using “subscription-manager-gui” command executed on console1
2) Execute same command “subscriptio-manager-gui” on console2

Expected Result:
Proper Message should display “ Subscription-manager is already running “

Actual Result : 
At step 2
Running subscription-manager gui got terminated 
Displayed following trace back on console 

(subscription-manager-gui:5318): libglade-WARNING **: unknown attribute `swapped' for <signal>.



(subscription-manager-gui:5318): libglade-WARNING **: unknown attribute `swapped' for <signal>.

subscription-manager-gui is already running

Traceback (most recent call last):

  File "/usr/sbin/subscription-manager-gui", line 108, in ?

    show = bus.get_object(BUS_NAME, BUS_PATH).get_dbus_method('show_window')

  File "/usr/lib64/python2.4/site-packages/dbus/proxies.py", line 25, in __call__

    ret = self._proxy_method (*args, **keywords)

  File "/usr/lib64/python2.4/site-packages/dbus/proxies.py", line 102, in __call__

    reply_message = self._connection.send_with_reply_and_block(message, timeout)

  File "dbus_bindings.pyx", line 455, in dbus_bindings.Connection.send_with_reply_and_block

dbus_bindings.DBusException: Message did not receive a reply (timeout by message bus)

[root@localhost ~]#
Comment 2 Bryan Kearney 2011-07-18 15:02:33 EDT
This appears to be fixed in master. Moving it to modified so that it can e verified.
Comment 4 J.C. Molet 2011-07-21 12:04:45 EDT
Verified in: subscription-manager-gnome-0.96.4-1.git.47.e65faae.el6.x86_64

it now does not open with the following message: 

subscriptoin-manager-gui is already running


moving to VERIFIED.
Comment 5 errata-xmlrpc 2011-12-06 12:14:23 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1695.html

Note You need to log in before you can comment on or make changes to this bug.