Bug 70644 - Toolbar buttons are too wide in redhat-config-users
Summary: Toolbar buttons are too wide in redhat-config-users
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-users (Show other bugs)
(Show other bugs)
Version: 8.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-08-03 00:05 UTC by Christian Rose
Modified: 2008-08-01 16:22 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-15 19:37:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot showing the toolbar buttons at default window size (25.95 KB, image/png)
2002-08-03 00:06 UTC, Christian Rose
no flags Details

Description Christian Rose 2002-08-03 00:05:24 UTC
Tested with beta4 and using sv_SE.

The toolbar buttons are too wide for the default window size; not all toolbar
buttons fit (see attached screenshot).

It seems all toolbar buttons share the same size, so all buttons get the size of
the widest one. Some button captions will inadvitely be wider than the original
when translated into another language, and it seems that when this happens all
buttons suddently won't fit.

I guess the best solution is to not set the same size for all buttons, but allow
them to have different widths. Another option would be to increase the size of
the default window, but I guess that is less desirable.

Comment 1 Christian Rose 2002-08-03 00:06:27 UTC
Created attachment 68664 [details]
Screenshot showing the toolbar buttons at default window size

Comment 2 Brent Fox 2002-08-06 19:12:36 UTC
The gtk guys say there is no way to make a toolbar have variable width buttons.
 Argh.

It looks like I'll have to increase the default window size, although that seems
like a pretty bad workaround.

Comment 3 Brent Fox 2002-08-06 19:21:01 UTC
Should be fixed in 1.1-10

Comment 4 Jay Turner 2002-08-14 20:09:43 UTC
I'm still seeing the same behavior with redhat-config-users-1.1-12 when running
with LANG=de_DE.UTF-8.

Comment 5 Brent Fox 2002-08-15 19:37:48 UTC
Good grief.  Ok, I've made the window a little larger to accomodate German. 
It's pretty silly that GTK makes the buttons all be the same size, but there's
nothing I can do about that.

Try with 1.1-13.  If this still isn't big enough for some languages, the users
will have to resize the window themselves.  I'm not going to have the window
default to 1024x768 in all langs just to accomodate one or two langs with long
strings.  Like I said, this is really a GTK problem that makes the buttons
spread out so wide.

Comment 6 Jay Turner 2002-08-21 19:29:08 UTC
Looks good to me with redhat-config-users-1.1-15.

Comment 7 Jay Turner 2002-08-21 19:39:50 UTC
Looks good to me with redhat-config-users-1.1-15.


Note You need to log in before you can comment on or make changes to this bug.