This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 70647 - service --status-all is broken
service --status-all is broken
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: initscripts (Show other bugs)
limbo
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-02 20:56 EDT by Michael Schwendt
Modified: 2014-03-16 22:29 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-20 05:49:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
proposed patch against /sbin/service (621 bytes, patch)
2002-08-02 20:57 EDT, Michael Schwendt
no flags Details | Diff
alternative cleanup patch (714 bytes, patch)
2002-08-03 07:07 EDT, Michael Schwendt
no flags Details | Diff

  None (edit)
Description Michael Schwendt 2002-08-02 20:56:50 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020724

Description of problem:
"service --status-all" does nothing because it goes into root directory and from
there does not find the System V init scripts.

One possible patch is attached. An alternative would be to use sed.

Version-Release number of selected component (if applicable):
6.88-1

How reproducible:
Always
Comment 1 Michael Schwendt 2002-08-02 20:57:27 EDT
Created attachment 68665 [details]
proposed patch against /sbin/service
Comment 2 Michael Schwendt 2002-08-03 07:07:12 EDT
Another thought...

Since service --status-all doesn't need to "cd /" unlike the start/stop options
and since the script does "cd /" more than once, maybe it would make more sense
to drop the "cd /" at the top and do "cd /" in the "service" script only where
it is really needed. Alternative example patch attached.
Comment 3 Michael Schwendt 2002-08-03 07:07:52 EDT
Created attachment 68705 [details]
alternative cleanup patch
Comment 4 Jay Turner 2002-08-05 09:34:03 EDT
Changing this to 'assigned' as modified inplies that changes have been made and
QA has signed off on the package.
Comment 5 Michael Schwendt 2002-08-20 05:48:56 EDT
Works again with (null), initscripts-6.90-1.

The redundant "cd /" in line 47 (--full-restart) is still there, though. The
single "cd /" at the top should be enough.
Comment 6 Bill Nottingham 2002-08-20 23:42:21 EDT
Extraneous / will be removed in 6.91-1.

Note You need to log in before you can comment on or make changes to this bug.