Bug 706563 - Xfce is unable to resolve hostname
Summary: Xfce is unable to resolve hostname
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xfce4-session
Version: 15
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Kevin Fenzi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-05-21 00:47 UTC by Raphael Groner
Modified: 2011-08-22 15:28 UTC (History)
9 users (show)

Fixed In Version: xfce4-session-4.8.1-5.fc16
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-03 02:31:31 UTC
Type: ---


Attachments (Terms of Use)
Suggested upstream patch to enable DNS only on availability of TCP (62 bytes, text/plain)
2011-07-25 17:57 UTC, Raphael Groner
no flags Details

Description Raphael Groner 2011-05-21 00:47:45 UTC
Description of problem:
I have entered "spritty.local" as the hostname for an anaconda installation from the Fedora 15 XFCE spin 64 bits nightly of 15th May 2011.

Version-Release number of selected component (if applicable):
?

How reproducible:
once

Steps to Reproduce:
1. Install Fedora 15
2. In anaconda, set an hostname (maybe with dot in it)
3.
  
Actual results:
XFCE complains after user login that no hostname could be found or resolved.

Expected results:
No error message after login.

Additional info:
I have added the hostname manually to /etc/hosts then. So, no warning message any more. The installer should do this automatically.

Comment 1 Radek Vykydal 2011-05-23 15:15:25 UTC
Anaconda only stores hostname in /etc/sysconfig/network. It doesn't touch /etc/hosts since F13 as it used to cause problems (bug #530343). I think that if anaconda should handle this case, then via NM which is updating /etc/hosts when hostname is supplied by dhcp.

Also I should note that this is on live CD which can make difference.

Comment 2 Raphael Groner 2011-05-23 18:20:20 UTC
It's not user-friendly how it is currently, sorry.

I am not familiar how Xfce tries to resolve the hostname, though it can read it - so it should be possible to resolve it, too …

Should this report go to the Xfce team?

Comment 3 Christoph Wickert 2011-05-23 19:21:26 UTC
I did a lot of test installs with the Xfce spin and I cannot reproduce your problem and IMHO there are valid reasons to not touch /etc/hosts. Could you give us a more details about your installation? Did you install form the Xfce spin of the DVD? Was NetworkManager/networkmanager-gnome installed and used or not?

Comment 4 Patrick 2011-06-09 12:11:19 UTC
I installed Fedora 15 x86_64 from the KDE live spin to my harddrive. During installation I changed the hostname to "tom.local" but /etc/hosts does not contain it. This was the reason why proftpd.service refused to start.

Comment 5 Piotr Orzechowski 2011-06-19 19:49:53 UTC
I have the same issue with XFCE and also set custom host name in anaconda (one word long, without dot). It is simply annoying, because XFCE doesn't load until "Continue" button on error dialog is pressed. I use wireless broadband modem to connect to Internet.

Comment 6 Raphael Groner 2011-07-22 18:23:42 UTC
I can reproduce here with Fedora 15 xfce i686. 
Rebooted a fresh installation with anaconda in VirtualBox 4.1

Switched to tty2 and tried the following commands.

# hostname
fedora15.vbox
# cat /etc/hosts
127.0.0.1 localhost.localdomain localhost
::1 localhost6.localdomain6 localhost6
# echo [$SESSION_MANAGER]
[]

An IPv4 address is assigned by DHCP and NetworkManager is running.

Comment 7 Raphael Groner 2011-07-22 20:58:08 UTC
This or a similiar issue is currently discussed upstream.

http://foo-projects.org/pipermail/xfce4-dev/2011-July/028979.html

Comment 8 Christoph Wickert 2011-07-22 21:22:55 UTC
As mentioned on IRC we are dealing with two different problems here:
1.anaconda does not add the hostname to /etc/hosts. This causes problems for services like proftpd.
2. is that xfce4-session relies on the hostname. As pointed out on the Xfce mailing list it should not rely on the hostname but only on localhost - if anything at all.

I suggest to track this in two separate bugs, one for anaconda and one for xfce4-session.

Comment 9 Raphael Groner 2011-07-25 17:57:13 UTC
Created attachment 515117 [details]
Suggested upstream patch to enable DNS only on availability of TCP

This patch was suggested at the upstream mailing list. Thanks to Guido Berhoerster, OpenSUSE.

Comment 10 Raphael Groner 2011-07-25 18:01:23 UTC
Comment on attachment 515117 [details]
Suggested upstream patch to enable DNS only on availability of TCP

This bug was suggested to upstream. Thanks to Guido Berhoerster, OpenSUSE.

Comment 12 Kevin Fenzi 2011-07-27 21:19:28 UTC
Can you confirm that this scratch build fixes the issue: 

http://koji.fedoraproject.org/koji/taskinfo?taskID=3234671

Comment 13 Raphael Groner 2011-07-27 22:30:04 UTC
(In reply to comment #12)
Yeah. The message box does not appear any more in my vbox/i686 installation.
Good job.

Comment 14 Fedora Update System 2011-07-27 22:50:52 UTC
xfce4-session-4.8.1-5.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/xfce4-session-4.8.1-5.fc16

Comment 15 Fedora Update System 2011-07-27 23:01:21 UTC
xfce4-session-4.8.1-5.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/xfce4-session-4.8.1-5.fc15

Comment 16 Fedora Update System 2011-07-31 03:45:54 UTC
Package xfce4-session-4.8.1-5.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing xfce4-session-4.8.1-5.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/xfce4-session-4.8.1-5.fc15
then log in and leave karma (feedback).

Comment 17 Fedora Update System 2011-08-03 02:31:24 UTC
xfce4-session-4.8.1-5.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 18 Fedora Update System 2011-08-22 15:28:34 UTC
xfce4-session-4.8.1-5.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.