Bug 70658 - vte no longer accepts input after resizing
Summary: vte no longer accepts input after resizing
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: vte   
(Show other bugs)
Version: limbo
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 67218
TreeView+ depends on / blocked
 
Reported: 2002-08-03 11:43 UTC by jeroen
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-07 09:50:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description jeroen 2002-08-03 11:43:22 UTC
I've got a vte terminal embedded in a GtkPaned (part of the anjuta2 project).
After resizing the terminal by dragging the GtkPaned, the vte widget no longer
accepts any keyboard input. It just sits there and doesn't respond to anything:
doesn't display any of the characters i'm typing, doesn't respond to "reset",
"clear" or "exit".

Resizing works fine in gnome-terminal.

Filing this @ bugzilla.redhat.com because of limbo.

Comment 1 jeroen 2002-08-07 09:50:55 UTC
It now works with vte-0.7.0 from rawhide.

There's still some garbage text which doesn't get cleared when you make the vte
widget smaller (the space below the last line in the vte widget which is smaller
than the height of a line doesn't get cleared).

Comment 2 Nalin Dahyabhai 2002-08-14 07:12:48 UTC
The hints on the widget shouldn't let you resize it to a non-integral multiple
of the character cell size.  The widget didn't set this geometry hint in the
past, but it should be fixed around 0.7.3 or so.  Closing.


Note You need to log in before you can comment on or make changes to this bug.