Bug 70659 - tunl devices need to be added to hotplug blacklist
tunl devices need to be added to hotplug blacklist
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: hotplug (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-03 09:07 EDT by Tony Nugent
Modified: 2007-04-18 12:45 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-03 09:19:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
custom init script that manages tunl devices on a dynamic IP (4.57 KB, text/plain)
2002-08-03 09:19 EDT, Tony Nugent
no flags Details

  None (edit)
Description Tony Nugent 2002-08-03 09:07:05 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.0 (X11; Linux i686; U;) Gecko/20020509

Description of problem:
I use ip tunnels frequently, I call the devices (appropriately)
tunl0, tunl1, tunl2 and so on.
Hotplug goes berzerk trying to do something with them, and it can cause problems.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Set up an ipip tunnel...
  modprobe ipip
  ip tunnel  add     tunl1 mode ipip local $LOCAL remote $REMOTE
  ip address add dev tunl1 $IPADDR peer $PEERIP
  ip link    set dev tunl1 up
2. The above is essentially what I have in a script I have made...
  /etc/sysconfig/network-script/ifup-tunl
  (Copy of this script is attached).
3. bad things can happen when I use this script...
	

Actual Results:  hotplug goes nuts unless "tunl" is added to /etc/hotplug/blacklist
when I attempt to bring up a tunnel device called "tunl"

Expected Results:  hotplug should not attempt to manage tunl, gre or any other
virtual network devices (such as dummy).

Additional info:

Please see attachment for my ifup-tunl script
(ok, it is messy, noisy and overly complex and
aggressively turns of firewall mods and so on.

Please see notes at the top of the script for further notes.

It works for me, it should work by default like any other
network device configured to be used with /sbin/ifup and family.
I have been using essentially the same script since rh62, and
hotplug has been the only real problem.
Comment 1 Tony Nugent 2002-08-03 09:19:16 EDT
Created attachment 68707 [details]
custom init script that manages tunl devices on a dynamic IP
Comment 2 Trond Eivind Glomsrxd 2002-08-07 11:56:54 EDT
Done, in hotplug-2002_04_01-9

Note You need to log in before you can comment on or make changes to this bug.