Bug 70660 - miniChinput chews CPU and memory
miniChinput chews CPU and memory
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: miniChinput (Show other bugs)
7.3
athlon Linux
medium Severity high
: ---
: ---
Assigned To: Yu Shao
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-03 09:48 EDT by Fergal Daly
Modified: 2007-04-18 12:45 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-06 01:25:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fergal Daly 2002-08-03 09:48:32 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020408

Description of problem:
Even if you're not doing anything, miniChinput sits there gobbling up
memory. I'm pretty sure it has been the cause of 2 out of memory/swapaholic
lockups in the last couple of days.

Also, while it's running, it's taking up about 10% of CPU time and X takes
another 20%, whereas without chinput, X uses about 0% when idle.         

It happens with versions 0.0.3-18 and -20                                      
     


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Set your language to Chinese
2.Log in to KDE through GDM (I presume this part is not important but just in
case, this is exactly what I'm doing)
	

Actual Results:  Even when not in use, chinput eats memory and uses CPU and X
uses lots more than it normally does when idle.

After some time massive swapping starts and everything locks up

Additional info:
Comment 1 Yu Shao 2002-08-09 08:30:47 EDT
miniChinput needs memory, but not that much, and I have never met it is being
locked. For -18 and above versions, the only thing I can think of is its huge
18030 font file(30000+ characters), perhaps X need more cache momery. You can
try wiht zh_CN.GB2312 locale, see if there is any difference.

Can you give me more cases of being locked or very slow?
Comment 2 Fergal Daly 2002-08-11 07:10:57 EDT
It turns out that the problem is somehow related to xterm also. I was
finding it impossible to replicate with a fresh account but this was because
I was using gterm or kterm with those accounts.

So to replicate it, create a fresh account, login in Simplified Chinese mode
and run xterm. If you run top in the xterm you should see that X, chinput
and the xterm are all busy doing something and chinput's memory usage is
increasing steadily. On my machine it goes up at about 20k per second and so
after about 5 or 6 hours it fills all of my ram and swap and things get
nasty.

Hope this helps.
Comment 3 Wesley Tanaka 2003-08-12 10:19:32 EDT
This happens to me with miniChinput-0.0.3-51.2 from rawhide.

from top:

  PID USER     PRI  NI  SIZE  RSS SHARE STAT %CPU %MEM   TIME CPU COMMAND
 3590 root      24   0 92980  19M  2496 R    34.9  7.6   4:38   0 X
 3983 wtanaka   15   0  7408 6512  1296 S    17.4  2.5   1:01   0 chinput
 4387 wtanaka   15   0  4432 4272  1952 S    15.5  1.6   0:37   0 xterm
 3977 wtanaka   16   0  8184 8184  3728 R     9.7  3.2   0:33   0 xmms
 3714 wtanaka   15   0  2536 2196   968 S     6.7  0.8   0:27   0 fvwm2
 3999 wtanaka   15   0 62112  53M 14904 S     6.7 21.5   2:25   0 mozilla-bin
 3991 wtanaka   15   0 16288  15M  8848 S     5.8  6.1   0:43   0 gedit
 4448 wtanaka   15   0  1104 1104   876 R     2.9  0.4   0:03   0 top
Comment 4 Lawrence Lim 2004-07-13 05:44:36 EDT
Is this still valid?
Comment 5 Lawrence Lim 2004-09-06 01:25:10 EDT
Closing this bug due to its age, and miniChinput has been ported to
IIIMF. Reopen this bug if necessary.


Latest rawhide is miniChinput-0.0.3-58.src.rpm. 

Note You need to log in before you can comment on or make changes to this bug.