Bug 70669 - firstboot does not read /etc/sysconfig/firstboot
firstboot does not read /etc/sysconfig/firstboot
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: firstboot (Show other bugs)
limbo
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks: 67217
  Show dependency treegraph
 
Reported: 2002-08-03 13:01 EDT by Dr. Tilmann Bubeck
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-13 21:43:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dr. Tilmann Bubeck 2002-08-03 13:01:51 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.0) Gecko/20020529

Description of problem:
I made a error during installation of the xfree stuff. So my machine was not
able to start XFree after installation when running firstboot.

I rebooted single user and read the comments at the start of
/etc/rc.d/init.d/firstboot telling, that firstboot will not start if the file
/etc/sysconfig/firstboot exists.

I created this file with "touch /etc/sysconfig/firstboot" and rebooted. But
still firstboot is trying to start X.

Please change something, so that there is an easy way to stop firstboot.
-OR-
make firstboot run without a proper X configuration by falling back to VGA?



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install
2. Make a wrong X configuration
3. crash
	

Actual Results:  Machine freezing because of incorrect XFree configuration used
by firstboot to start X

Expected Results:  No X at all or fall back to VGA

Additional info:
Comment 1 Brent Fox 2002-08-13 21:43:09 EDT
Ok, there are a couple of issues here.  One is that you need an easy way of
making firstboot not run.

One way to do this is to boot into runlevel 3.  I have changed firstboot today
to only start in runlevel 5.
Another way is to run 'chkconfig --del firstboot'.  That will prevent firstboot
from ever trying to start again.

Another is to create /etc/sysconfig/firstboot with the contents:
RUN_FIRSTBOOT=NO.
I know the comments in the Python said something diffrent, but they were wrong
but I fixed them a few minutes ago.

Another is to have firstboot have a way to recover from a busted X
configuration.  I'm working on this but I may not get it done in time for this
release.

I added some code today that will make firstboot call redhat-config-xfree86 if
/etc/X11/XF86Config file does not exist, which helps some.  But, this doesn't
handle the case of when /etc/X11/XF86Config file exists but is damaged so that
the X server can't start correctly.
Comment 2 Brent Fox 2002-08-13 21:47:40 EDT
But your original bug report is that firstboot doesn't read
/etc/sysconfig/firstboot.  It does, but it expects to find "RUN_FIRSTBOOT=NO". 
Therefore I am closing the bug as Rawhide.  The Docs group is working on better
documentation for this file.

Note You need to log in before you can comment on or make changes to this bug.