Bug 70672 - langsupport documentation issue for kickstart
langsupport documentation issue for kickstart
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-03 14:06 EDT by Denice
Modified: 2007-04-18 12:45 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-03-18 10:28:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
example kickstart file with sensitve stuff munged (3.34 KB, text/plain)
2002-08-03 14:15 EDT, Denice
no flags Details

  None (edit)
Description Denice 2002-08-03 14:06:14 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020607

Description of problem:
It turns out to be important to specify the default language twice in the ks
configuration file when you install more than one language on a kickstarted
system.  The documentation example is wrong in the customization guide:
 "For example, to install English and French and use English as the
  default language:
  langsupport --default en_US fr_FR
 "
If you do this then you will only have french locale glibc files in
/usr/lib/locale/

Moreover, you environment in /etc/sysconfig/i18n will list only
fr_FR:fr as supported locales.

The correct format for the langsupport item is, for example:
 langsupport --default en_US.iso885915 en_US.iso885915 fr_CH

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. try my config file (attached)
2. during installation toggle to the shell and look in:
     /mnt/sysimage/usr/lib/locale/
3.
	

Additional info:
Comment 1 Denice 2002-08-03 14:15:20 EDT
Created attachment 68745 [details]
example kickstart file with sensitve stuff munged
Comment 2 Jeremy Katz 2002-08-03 17:08:27 EDT
Fixed in CVS so that the default language is always in the list of languages
installed
Comment 3 Mike McLean 2003-03-18 10:28:39 EST
Closing.

Note You need to log in before you can comment on or make changes to this bug.