Bug 706783 - Running meld gives "Cannot import: pygtk"
Running meld gives "Cannot import: pygtk"
Product: Fedora
Classification: Fedora
Component: meld (Show other bugs)
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Dominic Hopf
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2011-05-22 20:17 EDT by Mark Stock
Modified: 2011-07-18 08:05 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2011-07-18 08:05:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Mark Stock 2011-05-22 20:17:44 EDT
When I run "meld" on my Fedora 14 desktop (upgraded from F13 recently), I receive the error messages:

$ meld
Cannot import: pygtk
No module named pygtk

My new netbook, which received a fresh F14 installation, does not exhibit this problem.

All other software is up-to-date. Meld is meld-1.5.1-1.fc14.noarch

I have tried "yum reinstall meld" and "yum reinstall meld pygtk2" to no avail. Not willing (yet) to "yum remove pygtk2", as it wants to yank most of gnome.

Googling the errors and "fedora 14" only returns my lonely post on fedoraforum.org.

I am open to suggestions. Thank you.

Comment 1 Christoph Wickert 2011-05-23 03:31:20 EDT
This is probably a duplicate of bug 649507. The problem only appears in upgraded versions of python.
Comment 2 Mark Stock 2011-05-24 11:47:03 EDT
Should I follow developments there? Do you need any more information to progress?
Comment 3 Dominic Hopf 2011-06-01 18:55:34 EDT
Hi Mark, since this seems to be a generic issue with current python versions it is likely this will be fixed soon. For you in special there is nothing special to do at present, you already did the most important thing and reported this issue. :)

Of course you can keep an eye on other similar python issues, but we would keep you up-to-date anyway.
Comment 4 Mark Stock 2011-06-12 18:15:00 EDT

I might have solved my own problem. I installed Vapor-2.0.0 a while ago, which comes with its own python (unbeknownst to me). The installation instructs the user to add

. /usr/local/vapor-2.0.0/bin/vapor-setup.sh

to his .bashrc. With that in place, "which python" returns


I removed that entry, logged out and back in, and now meld (and pitivi) work.

I feel dumb for not even trying "which python" before, but so many other things worked, and I just didn't realize that so many programs are python under the hood.

Thanks for taking me seriously, even though this turned out to be user error (in a way).

Comment 5 Dominic Hopf 2011-07-18 08:05:44 EDT
Thanks very much for your feedback, Mark! I'm closing this bug. :)

Note You need to log in before you can comment on or make changes to this bug.