Bug 706864 - Subscription-manager-gui command displayed Traceback and RuntimeError for runlevel 3
Subscription-manager-gui command displayed Traceback and RuntimeError for run...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 6.2
Assigned To: Bryan Kearney
spandey
:
Depends On:
Blocks: rhsm-rhel62
  Show dependency treegraph
 
Reported: 2011-05-23 05:51 EDT by spandey
Modified: 2015-04-23 19:56 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-15 11:51:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description spandey 2011-05-23 05:51:13 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
3/3

Prerequisites :
Client : Rhel5.7 with following subscription manager client 
subscription-manager-firstboot-0.95.5.18-1.git.4.364aa10.el5

subscription-manager-0.95.5.18-1.git.4.364aa10.el5

subscription-manager-gnome-0.95.5.18-1.git.4.364aa10.el5

Steps to Reproduce : 
Boot client in run level 3
Execute subscription-manager-gui command on root console.

Expected Result : 
No Traceback should display .
Proper message should display for “Xserver” requirement .

Actual Result : 
Traceback (most recent call last):

  File "/usr/sbin/subscription-manager-gui", line 30, in ?

    import gtk

  File "/usr/lib64/python2.4/site-packages/gtk-2.0/gtk/__init__.py", line 76, in ?

    _init()

  File "/usr/lib64/python2.4/site-packages/gtk-2.0/gtk/__init__.py", line 64, in _init

    _gtk.init_check()

RuntimeError: could not open display
Comment 1 Chris Duryee 2011-05-23 10:19:56 EDT
This is working properly, since subscription-manager-gui cannot run without X. However, a better error message would be nice. Moving to 6.2.
Comment 3 Chris Duryee 2011-08-15 11:51:20 EDT
I tested this against a few other pygtk apps (caribou, system-config-date, meld) and they exhibit the same behavior. After seeing the other apps, I believe the error message should stay as-is, since it is more informative than a generic "cannot find xserver" message.

marking as NOTABUG, feel free to alter if you disagree though.

Note You need to log in before you can comment on or make changes to this bug.